Wrong native language activated for the course

Hi,

When I select to browse French courses and then select that I speak European Portuguese I get a list of courses (with the official courses I suppose), but when I open French 1 (I didn’t try the other numbers) I get the course for Brazilian people to learn French instead of European Portuguese native speaker. You can immediately tell it’s the wrong Portuguese version because the pronouns are wrong and some things don’t make much sense.

Can you please fix it?

Not sure what you did, but here’s a list of French courses for speakers of (European) Portuguese:

FWIW, I’d recommend to always search for (new) courses on the web. This applies particularly if you’re using the app - in the app you have only a very limited selection of courses and there’s only Memrise courses. Also, when you pick a (new) course, start the first session on the web. You’ll then see that course appear on the app the next time you open it.

1 Like

Hmm. I just found out that the French courses that appear in the above search are actually EN-FR.
@MemriseSupport: isn’t there a FR-course for speakers of (European) Portuguese …?

Hi both. Unfortunately, we don’t currently offer official French courses for European Portuguese speakers. @luisnreis, using Olaf’s link above, you may wish to browse community-created courses (just scroll pass the Memrise courses 1-7) or alternatively, learn from Brazilian Portuguese or English.

2 Likes

Alright, thanks. But it’s misleading though. It should just show an empty course list, or have a message saying it’s not available and to try a different language. This way we keep wondering why the wrong language keeps coming up, leading to a big fight with the app or the website.

2 Likes

Seconded. Showing courses of a different source language is definitely a bug and absolutely unexpected.

1 Like

Hi @MemriseSupport,
Could the language pairing be made clear in the course title, description or icon?

PS

Icon : eg at the bottom left ‘my’ language as a small flag and bottom right as a ‘target’ language flag.

At the moment, our course descriptions don’t detail explicitly who the course is for. To get the French course for Portuguese (Brazil) speakers, users would need to select ‘I speak…Portuguese (Brazil)’ and then French. Selecting ‘I speak…Portuguese (Portugal)’ will bring you to the English version of the French course. However, if we get further reports of confusion from users we will put this forward to our Content team :slightly_smiling_face:

2 Likes

Ah well, what can I say … :slight_smile:

I also find this confusing - I’d encourage you to forward the issue to your Content team as soon as possible.

1 Like