Words re-introduced during revision


(Dylan Nicholson 548) #1

I’ve noticed recently (using website) while revising/learning that I’m getting re-presented with terms as though it’s the first time I’ve seen them, even though I’ve definitely already seen them before (from the same course).
In some cases I’ll get presented with a term as though it’s the first time, then almost immediately prompted to type the corresponding ‘answer’ when prompted with the question, which isn’t something I’ve ever observed when they really are brand new terms.
Has there been a recent change to the learning/revision methodology and if so what’s the reasoning behind it? For me I don’t feel like my revision/learning attempt counts for anything if I’ve literally just been given the answer a few seconds before…


[Userscript] Memrise Auto Learn
(Dylan Nicholson 548) #2

So I confirmed what’s actually happening is that it’s only words that I haven’t fully “planted” yet, and during the next learning session, it will still present those words as though they’re brand new.
I don’t remember that happening in the past, and I definitely feel it takes away from the learning experience - technically I can get a word to “fully planted” over several learning sessions when all I’m doing is proving I can remember something I’ve just been shown…


(Thomas Heiss) #3

@dylan.nicholson.548

Hi Dylan,

this might also depend on the course.

Can you link it?

Some time ago I had seen a forum thread that the website now also uses the “mobile app - half-planting” concept for their offical 1-7 courses.

If you have not already stepped through the six planting steps, you will still be in the learning mode when you start the 2nd learning session next time.

Cooljingle had a user script in 2017 called “Memrise learning retries”: https://github.com/cooljingle/memrise-learning-retries

Last update was in Sept 2017, maybe it does not work anymore…have not used it recently.

The “Memrise-infinite-learning” user script from March 2018 does unfortunately not work anymore AFAIK. Last time I tried it freezed the question loading screen because of newer website (module) updates by Memrise staff.

…(…)…

Actually I don’t think that the “half-planting” concept is too bad…maybe not useful for all times.

I used it sometimes on an Android emulator software to learn the first 10 words of multiple levels…when I tried to push forward with a course.

But I had a break of at least 1-2 weeks between the two sessions for those first 10 words.

I am not sure if it really makes always sense to go through easier words in 6 planting steps…AnkiSRS has less “learning steps” (by default 2, you can define them manually)…or you can press the EASY button which Memrise does not have.

For EASY words to SKIP the six planting steps you can use Cooljingle’s Tampermonkey “Auto learn” user script: https://github.com/cooljingle/memrise-auto-learn


(Thomas Heiss) #4

Personally I leave the “learning mode” to Memrise’s default (mixing multiple choice, listen audio, 1-2 typings, etc.).

But if you really do not want this, you can switch an option to **full typing for the “learning mode” in the script settings on the left side in Cooljingle’s Tampermonkey user script “all typing”: https://github.com/cooljingle/memrise-all-typing

My personal setting is to enable it for REVIEWS.
I have disabled learning.
6x typing in the very beginning would be too much for me for more difficult or longer words.

When the script is activated, you will see a new “typing settings” link on the left menu panel (where you can find audio options) when you have started a learning or review session.

My advise would be to use “all typing” for reviews (to turn OFF multiple-choice on the web portal) and to use “Auto learn” for EASY words to skip the six planting steps.

If Memrise splits the six steps into 2x3 the better if you have the time.

You just need to be aware that the default Memrise spaced repetition next review interval is 4-5/6 hours, and then 12 hours: http://memrise-users.wikia.com/wiki/Memrise_Spaced_Repetition_Intervals

But with “half-planting” of several levels you can manage to avoid overfilling your review queue if it is not empty…but still learn (first time see) NEW words in multiple levels.

And YOU define the spacing when you resume the 2nd learning session for those words, e.g when you exactly know that you can review in the next 4-6 hours once fully planted (6th step executed).

Having to do “Overdueness” reviews (as you could not review in-time the 4h+12h intervals) is not the best for difficult words.


(Dylan Nicholson 548) #5

I’m using the auto-learn tampermonkey script but it actually doesn’t seem to be working any more (it was a couple of weeks ago). I suppose it’s when that stopped working I suddenly started noticing that the next time I go to learn new words, I’m getting presented with terms I’d already started learning as though they were new. But I don’t remember ever seeing this behaviour in the past. It’s really quite off-putting - if I’ve done 5 out of 6 skip learning steps in my last session, I don’t want to be shown the full word+translation when I resume in the next session - I want to test myself that I’ve remembered it!


(Thomas Heiss) #6

Hi Dylan,

can you link your specific course (from the web portal) where you are having problems with?

Is it an official Memrise course from the 1-7 series?

Have you double checked the flower (and step) and if the new learned words gave you any half-planted progress bar or are fully planted with the water symbol and a due in 4-5h / now text written on them?

You may have to switch to the level which you have recently learned 10-15 words in.

My test with Auto-learn was successful: [Userscript] Memrise Auto Learn

Maybe there are now some strange side dependencies with planting on the offical 1-7 Memrise courses, changes with reviews or whatever.

Hard to tell…the question is how it can be replicated.

If you have any chance to record a video on a) planting new words with Auto-learn and b) how the review behaves and if you use Cooljingle’s “all typing” user scripts for reviewing of fully planted words or not it maybe would be possible to track it down what minor code detail it is…

If there have been any web updates by Memrise staff in the past weeks it could explain why you run into it…

UPDATE: Forget this thing about offical 1-7 Memrise courses.
I have found your learning profile: https://www.memrise.com/user/dylan.nicholson.548/courses/learning/
You just have added user-created courses…