[wiki] All the Userscripts

wiki
userscript

(Cooljingle) #43

I’ll be slowly repairing the scripts when I get the chance; I had a stab at fixing the all typing and audio provider scripts but it looks like they still have some issues.


#44

Many thanks @cooljingle. You’re the best! :clap:


(Matteogiuseppe) #45

Thank you! You’re awesome.:grinning:


(Fandeseriea) #46

Hi, could you tell me how you did it? This script is exactly what I’m looking for!


(Overlord Hydroptère) #47

disable auto-accept:
https://github.com/stream009/greasemonkey_scripts/raw/master/MemriseDisableAutoAccept.user.js

block ziggy from user Pope Pous the Ninth
Step 1: Get Adblock

Step 2: Filter Preferences -> Custom Filters -> Add filter Group

Step 3: Actions -> Show/hide filters -> Add Filter

-> copy paste: memrise.com##img.rank-icon

Even more EZ:
Right click on the element and “Adblock Plus: block image”

how to block the guessing keyboard (kindness of user @lprg)


(Ansa211) #48

Just an idea for someone who would like to implement a script that prolong the 180 days repetition period for 360 days… what about automatically filling in the right answer on the 180 days “anniversary”, so that it gets skipped from the user’s point of view? Judging by the fact that “Memrise Auto Learn” exists and works properly (it allows for skipping some of the 6 repetitions during the initial planting phase), it could be possible - even though it might require creating a local database of all the learned vocabulary to 1) keep track of what value needs to be filled in and 2) keep track of which repetition should be skipped and which not.


(Matteogiuseppe) #49

@cooljingle
Looks like some Memrise update has caused your ‘all audio multiple choice’ and ‘reverse translation’ scripts to break. Any chance you could take a look? :pray: :pray:

I’m on FF/OSX using Tapermonkey.


(Thomas Heiss) #50

"Timer Disabler" (correct link is already in Arete_Hime’s Wiki list) got an update to V0.1.6:


(Cooljingle) #51

I’ve submitted fixes for those 2 scripts :+1:


(Matteogiuseppe) #52

Dude, thank you so much. I really really appreciate it and your efforts!:muscle:


(Matteogiuseppe) #53

**EDIT: This issue appears resolved. I’m sure it was on my end. My apologies.


(X Water Lily) #54

@cooljingle I’m having an issue on Firefox where it will say on greasemonkey that the script is in use on memrise but isn’t showing the sidebar option for reverse translation. What am I doing wrong here?


(Cooljingle) #55

I haven’t tested but I recall others having trouble getting scripts to run via greasemonkey. Perhaps try using the Tampermonkey addon instead to see if that works?

If that is the issue I’ll go update the readmes so as to recommend using Tampermonkey over Greasemonkey.


(X Water Lily) #56

@cooljingle I tried it with Tampermonky and it all worked fine. So I think it’s wise to recommend users use tampermonkey over greasemonkey. Thanks for the help. :slight_smile:


(The Four Gated Danzig) #57

It looks like after whatever update today to add the particle of speech under the word, auto-learn doesn’t work anymore. @cooljingle

Anyone else experiencing this?


(Cooljingle) #58

yeah, the script wasn’t working after the update. I’ve updated the script again to get it working (v0.0.10).


(The Four Gated Danzig) #59

Sorry to bother you, m’Lord, but one comment:

it looks like it’s glitching a little in that sometimes one word will not fully auto learn, so you’ll see it come up in the next session with 1 planting left for it to be learned.


(Cooljingle) #60

Is it the final word in the session that does this? I think it could be because there’s a delay in getting all the words autolearned so if you change screens too quickly after the session ends it doesn’t have time to complete the plantings. I’m not sure of way around that so just waiting a bit longer at the end of the session might be the only recourse for now.


(The Four Gated Danzig) #61

The word has been random, but now that you mention it, I think most of the time it’s the last word, yeah.

Well, not the end of the world. One word less vs. not having the script at all, obviously the former is the better of the two evils.


(The Four Gated Danzig) #62

@cooljingle looks like the all multiple choice script stopped functioning?