[wiki] All the Userscripts


(Cooljingle) #23

here ya go: https://github.com/cooljingle/memrise-all-audio-multiple-choice

(Matteogiuseppe) #24

Dude, you are amazing. A sincere and heartfelt thanks - this is perfect :grinning:

(Data Disk) #25

Thanks, very useful.

Is there a way to keep the text when using the script? With the script running there is no translation when Spanish Adio ->_ Spanish Muliple choice. I’d really like to see the english translation so keep memory fresh.

(Cooljingle) #26

if you’d rather pick from the English rather than the Spanish you could try running this reverse translations script: https://github.com/cooljingle/memrise-reverse-translations

(Data Disk) #27

Sorry, my mistake. I was thinking of the fields called “literal translation” and “english translation?” They seemed to have gone using the script. I still would like to do the Spanish -> English.

(Cooljingle) #28

Sounds like you’re referring to data from the other columns? They don’t usually get displayed do they? In any case, the script probably couldn’t help you in that respect.

(Data Disk) #29

This is what I mean:

But I can’t remember if that only displays when you type the wrong answer. I will try the other script you mentioned to see if it provides Literal translation as a clue to which option is correct.

Or maybe I’m just to overheated in my cabeza because of testing so many language services and I’m starting to mix it all up;)

Anyway, thanks for prompt and kind help:)



Interesting! Sometimes when I’m reviewing, I notice that I need to reset the ‘more’ button. I’m not sure what causes it to switch to ‘less’ on those ocassions or if having the ‘all typing’ script switched on makes a difference.

I’ll try to remember to look for reasons why this sometimes happens but, in the meantime, I wonder if that’s what’s happening to you.

(Matteogiuseppe) #31

Anyone having problem with the reverse translation userscript?

@cooljingle I’ve got it installed in Greasemonkey but for whatever reason when I’m doing a review, it is inconsistent. (I’ve tested in both FF and Chrome and can’t get it to perform consistently.)

After I set toggle to reverse translation during a review session in the left hand column, the toggle stays set but the cards go back to asking for the non-reverse translation.)

(I’m studying Mandarin from English fwiw)

Love your stuff :grinning: and sorry to be a pest but I figured I’d see if you knew what was going on in case I was doing something wrong. I just pulled latest from git btw. Cheers!

*Edited to add that I’m trying to use in conjunction with your all-multiple-choice script. Not sure if there is a conflict or not.

(Matteogiuseppe) #32

Here’s a couple of screenshots of the questions not consistently being reversed:

(Neoncube) #33

@alanh, I think pressing one of the letters (‘m’?) when not focused on the input box, when on the screen where the “more” information is present, causes this, so if for some reason you’re not focused on the input box and start typing, this can happen. The same thing happens with ‘i’ and “ignore”, which can be kind of dangerous sometimes, haha.

I think this setting is also stored locally on your machine, so if you wipe your local data, then it resets, too.


@neoncube, Thanks! That may be it. I’ll watch out for it.

(Neoncube) #35

@alanh cool :slight_smile: I checked after posting, and it appears that the hotkey is “s”.

(Cooljingle) #36

There’s a fix but it’s a little confusing!

Basically memrise sometimes decides to randomly switch round the testing direction - not sure if it only does it for certain test types but audio multiple choice is definitely one of them. I did make a script to suppress that behaviour: https://github.com/cooljingle/memrise-no-reverse-translations

Unfortunately the names of the scripts are rather similar so you’ll have ‘Reverse Translations’ and ‘No Reverse Translations’ running together!

Update - Reverse Translations script will now enforce testing direction so with that running the No Reverse Translations isn’t required.

(Matteogiuseppe) #37

Thanks @cooljingle !:slightly_smiling_face:

Can I ask if I need to run the scripts to execute in a certain order?

For instance, if I want ONLY reverse translation multiple choice tests, would I run the following:

  1. All multiple choice script
  2. Reverse translations script
  3. No reverse translations script

Or do 2 & 3 cancel each other out somehow?

Let me know what you think

Edited: Just reread your post and you were clear, apologies for reading too quickly. I gave it a test with all 3 scripts running and it seemed to do the trick. Thanks again! :relieved:

(Neoncube) #38

Hey guys,

I just released a userscript for course creators that’s supposed to attempt to remove phantom entries from a course. It’s here.

(Casper Duo) #39

I’m having an issue with the turbo script.
The audio from the previous question and the next question play at the same time and overlap so you can’t hear either of them.

Can someone please try to fix it? Thanks.

Regarding @cooljingle Memrise Infinite Learning
It is not really infinite while doing new lessons (green button).
After you completed a lesson it stops the session.
I would like it to continue passed that.
Preferably I would like it to stop loading them only after, for example, a keyboard key is pressed or your goal is reached.
If the lesson is small you reach the end of it way too quickly.

(Thomas Heiss) #40

“Infinitive learning” script works “infinitive” for reviewing your course backlog.
It may even work with the global review per language (I have not tested).

Memrise uses the green “Learn” button by selecting the last level, or once you have finished it, a click on the green button it opens the new level, where you have to click again on the next green button.
At least this was the case when I tried to play with the normal green buttons.

“Infinitive learning” script can probably only poll that new vocabulary what it can receive from the Memrise API.
But for more details you better go to that script thread and discuss it in more details.

For the turbo script:
Have you already tried “AutoCorrect” from Cooljingle?
I have no problems with audio there, even I installed the “Audio-Provider” plugin in parallel (and lot’s of other scripts).

AFAIU it probably should work just like the turbo script where you can play around with words, but you still can hit the enter key. Maybe there are some smaller differences. I like it really much.
You could try to use it until the audio bugs are fixed in the turbo script, which “only” jumps from one question to the next once you have entered the correct sentence and helps you to complete the words including special characters (however, I have NOT tried it yet, I probably should).

(Hill1014) #41

Hi! Was wondering if anyone knows of a script to disable the typing tests and only the typing tests. I’d like to keep the audio, tapping, and multiple choice questions.

(Matteogiuseppe) #42


FYI It looks like Memrise’s latest (partial?) update has broken your Reverse Translation & All Audio Multiple choice scripts. (Your Multiple Choice appears to still function.)

Not sure if they are still updating but I figured I’d let you know…

Thanks for all your work, btw. It’s made my Memrise learning 10 times more effective.:muscle: