Why isn't it easier to format mems?

I’m adding mems to the Japanese 1 course because they aren’t there for kanji, surprisingly. But I can’t get it to format at all in an organized way.

I’d like it to look:
kun-yumi: しし shi shi
on-yumi: ニク niku

But instead it’s got it all in a single line, like this:
kun-yumi: しし shi shi on-yumi: ニク niku

It looks awful. I’ve tried a little html with a “br” command but that doesn’t seem to work, although I could be doing it wrong. Does anyone know how to format mems?

1 Like

Well, it turns out I actually can’t edit any mems, I get a “CSRF failed” error message, but there’s no mention of what that is in the Help articles.

Hi @hollyautumnlane,

Well, it turns out I actually can’t edit any mems,

Try going to your home page and getting the Mems to display then you should be able to edit them.
ie https://www.memrise.com/user/hollyautumnlane/mems/created/

1 Like

All you need to do is to hit return to move the text to a different line.


I did that.


that’s exactly what I’m doing that gives me a CSRF failed error message.

(moved the thread to “web bugs”, as it seems it is about a bug… or something similar)


moved the thread to “web bugs”

Thanks @Hydroptere, that is what I was thinking, as it should work.

1 Like

Can you provide us a screenshot of the CSRF error which also displays your entire screen?

I don’t believe we support multiple lines. If you attempt to make multiple line of text, it will be converted to a single line.

Here are the two formats which we do support.

1 Like

Well that sucks. It would be really useful to do a line break.

Hi @hollyautumnlane,

Here is a workaround that should allow you to do line breaks:

First, make a screenshot of a section of a blank page. For example, select one from “blank page” in Bing Images or similar. Then save your screenshot for future use.

Next, when creating your mem, upload the blank image. Then add your text and position it using the arrows etc. You should find that you can do line breaks.

The text will appear as white on black, rather than black on white, though!

PM me if you need any help.

You can make them appear on two different lines by adding an extra return/enter between them. It worked normally for me yesterday when creating new mems.

Typing this:

kun-yumi: しし shi shi {return}
on-yumi: ニク niku

Results in this:

kun-yumi: しし shi shi

on-yumi: ニク niku

1 Like

I’m not actually able to edit any mems, it seems…


Does it make any difference if you leave the comma out?

Was this mem created on a mobile device?