Why is there no "edit" button while watering a whole topic?

During watering, there is a button on the left side (next to “mute audio” and “keyboard shortcuts”) that lets one edit the current item if they are the course creator/contributor. That is really convenient - if I spot a mistake in my own entry, I can jump to editing it with a single click, instead of waiting to finish my current reviewing session (during which time I might forget what it was that I wanted to edit), going to the course manually and searching for that particular item. A great thing!

However, that only happens when I’m watering an individual course. If I try reviewing a whole subject (say, “German”), with words popping up from all the courses that have items ready for watering (which is in itself a very practical thing, too), the “edit” button isn’t there. Now, I know that’s because not all of those courses are my own, but it would still be extremely convenient to have it. Can’t it just 1) pop up on those items that are from my courses? or, if that’s hard to pull of fore some reason, 2) be present all the time, but simply do nothing/give an error if I try editing an item I’m not allowed to edit?

Thanks in advance for any feedback!

1 Like

I have no answer for your question, but now I know that I can review all items from one subject at once. Tried it out, brilliant, thank you!!

Agreed. While the bug should be fixed if possible, it’s nice to know there’s a way to review all your courses at once assuming they have the same category tag.

If case people want to know the steps, “Filter” your home page listing to a specific category like “Japanese” and all the reviews due in all your courses with that category can be reviewed all together.

*note: If you use Tampermonkey to disable your timer, it does not appear to work with the category review.

1 Like

Luckily category review does work with the Greasemonkey disable timer script installed.

Here is the script:

// ==UserScript==
// @name           Memrise Timer Disabler
// @description    Disables the Timer on watering & gardening levels in Memrise.com
// @match          http://www.memrise.com/*
// @version        0.1.2
// @grant          none
// @namespace https://greasyfork.org/users/3656
// ==/UserScript==
// Forked from http://userscripts-mirror.org/scripts/show/174879
// Corrected @match

var onLoad = function($) {
  $("div.garden-timer div.txt").bind("DOMSubtreeModified", function() {

var injectWithJQ = function(f) {
    var script = document.createElement('script');
    script.textContent = '$(' + f.toString() + '($));';

You’re probably using a version of the script that has something else than:
// @match http://www.memrise.com/*

I do see the edit button while watering the category. I only take my own courses. Perhaps the button is there when all the courses in the reviewing session are your own?

1 Like

Hmmm, that’s possible. But I definitely use courses other than my own in most categories, and I presume most people do, too, so that’s not too helpful generally.

Update: the situation has changed. Now it does give me the edit button for the course where I am the creator, even if the session is mixed (if someone in the team changed that, thanks a lot! :slight_smile: ), but, funnily enough, not for the one where I am just a contributor.

1 Like

Update 2: And now it’s not working again, i.e. I don’t get the button even for my course. Beats me why. :slight_smile:

1 Like

I know I’m behind and this is an old thread but, I didn’t know about this feature. That is awesome.