[WEBSITE-975] Completed courses show up as un-finished (Web / Mobile)

Description: Deleted grammar items are being counted in courses, making them impossible to “finish”.

Status: Unresolved

Please Note: If you are experiencing this issue we can confirm the course is finished, but due to the removed grammar items (on our end) it may show as un-finished. We would suggest moving on to the next course in the series while we attempt to resolve the issue.

Related Issues:

  1. [WEBSITE-846] Ghost Words in Community Courses (Decks)
  2. [QA-207] Completed courses with ignored items show up as unfinished on (Android)


18 Likes

Are you sure that the grammar bot is the reason for the problem? Because I have a whole bunch of community courses that show the same behavior and as there is no grammar bot for them the problem should at least have another background.
My guess / something I’d repro: this could be connected to courses where words/phrases have been removed after their original creation.

The community course issue is very similar (almost identical) but a separate issue, which we are aware of. It’s very confusing as there are a number of bugs which produce the same outcome, but the cause can be separate.

This is probably the most likely cause for community course showing up as un-finished. The Decks squad are aware of this and will hopefully addressing this shortly. I’m going to raise another Known Limitation now.

6 Likes

@Olaf.Rabbachin [WEBSITE-846] Ghost Words in Community Courses (Decks)

8 Likes

In case it helps anyone: I ran into this issue with the Chinese 2 course (I did the whole thing on web), but was able to get it marked complete by doing the grammar exercises in the mobile app afterwards.

3 Likes

@MemriseMatty, I have an incomplete course. I’ve gone through every level and there are no ignored words. It’s a conjuguation course so no grammar. I have tried completing it on the web (not Decks as yet) and also on the App. It still shows 1888/1889 words learned on both the web and the App and is most frustrating not being able to finish it. Any ideas on this one? Thanks.

Yeah, this happened to me with Japanese 0 and now has happened with French 1. With Japanese 0 I was always stuck with 208/210 words learned, and I got the “could not load session” error every time I tried to learn new words. Now on French 1 with 9 new words to go I have the same problem :frowning: I want to complete the course!!! @MemriseSupport

2 Likes

And now the same thing has happend on Korean 1 with 8 words to go :frowning: It would be nice just to have the satisfaction of having a course marked as complete.