Userscripts [e.g. Memrise Turbo and Memrise Timer Disabler] and some userstyles stopped working with today's web update

userscript

(Kim) #41

Mille mercis !!!

Up later than I should be so I thought I would try them. Both were VERY quick solutions and they both worked perfectly!

You are the best.

Cheers


(Maxine Downunder) #42

Thanks @ripcurlgirl. I must say it’s all very annoying when it was working brilliantly since I first installed it! Thanks again - I’ll try to work my way through this.


(Maxine Downunder) #43

Hi @ripcurlgirl, I just checked again and the only item I have under “Installed Userscripts” is “Memrise Turbo”. I’ll take a look at reinstalling although my memory tells me I had difficulties the first time around so I was so happy when I did get it working!


(Kim) #44

Sorry Maxine but not not having a Mac I can’t relate. Add to that the fact that, even though I was a computer operator way back in the days before Bill Gates and Steve Jobs where computers consisted of massive disk drives (the disks the size of LP records that were stacked on a spindle), large magnetic tape reels and absolutely humongous CPUs that held less than most usb thumb drives are capable of these days, I am incredibly ignorant when it comes to computer scripts and associated technology.

Kim


(Maxine Downunder) #45

No need to apologise Kim - I appreciate all your assistance thus far. I’m going to put in on a back-burner for now. Merci beaucoup.


(Frankiebluej) #46

I finally just searched “Memrise Audio Provider cooljingle” and I got his link: https://github.com/cooljingle/memrise-audio-provider

I downloaded it again and now it works beautifully. Thanks @cooljingle I appreciate it.

~frankieb


(For S Sberg) #47

Any success with error? Solutions above didn’t work for me.

Uh-oh, something went wrong. Click OK to resume your session. (CSRF Verification Fail)"

Without Memrise Turbo, reviewing 200 words per day takes enormous amount of time.


(Neoncube) #48

@ForSSberg, are you referring to CoolJingle’s MemriseTurbo script? If so, I thought he posted an update for it, although I’m not sure. If he did, you should just need to update the script.


(Gabriele Cramer Knebel2d) #49

@neoncube, the Memrise Turbo script is not Cooljingle’s script. That script was written by @infofarmer.

I have send @infofarmer a private message to let him know. Hopefully he can fix the script. I need that one working too. :joy:


(Neoncube) #50

Ah, I see :slight_smile: I wasn’t sure.


(Overlord Hydroptère) #51

anyone, a line of code/script for disabling the new avatar?


(Zimorodokan) #52

some changes to Memrise Turbo

` // ==UserScript==
// @name Memrise Turbo
// @namespace https://github.com/infofarmer
// @description Makes Memrise faster
// @match https://www.memrise.com/course//garden/
// @match https://www.memrise.com/garden/water/*
// @match https://www.memrise.com/garden/review/*
// @version 0.1.8
// @updateURL https://github.com/infofarmer/memrise-turbo/raw/master/MemriseTurbo.user.js
// @downloadURL https://github.com/infofarmer/memrise-turbo/raw/master/MemriseTurbo.user.js
// @grant none
// ==/UserScript==

var oldstart = MEMRISE.garden.feedback.start;
MEMRISE.garden.feedback.start = function (){
    if (MEMRISE.garden.box.state === 'choosing-mem') {
        oldstart(1);
    }else{
        MEMRISE.garden.box.next_press();
    }
};

$('body').on('input', function(e) {
    try {
        if ($(e.target).is('.typing input.typing-type-here')) {
            var g = MEMRISE.garden;
            var b = g.box;
            var s = g.scoring.score_response(
                b.$input.val(), b.testData.accepted, b.learnable.is_typing_strict);
            if (s === 1) {
                MEMRISE.garden.box.check();
            }
        }
    } catch (err) {
        console.log('error - falling back to default behavior', err);
    }
});

// always let audio play in full
MEMRISE.audioPlayer.stop = $.noop;
MEMRISE.audioPlayer.stopAfter = $.noop;

// disable pausing (especially automatic)
MEMRISE.garden.pause = $.noop;

// always disable timer
$("div.garden-timer div.txt").bind("DOMSubtreeModified", function() {
    MEMRISE.garden.timer.cancel();
});

// disable alert on exit
MEMRISE.garden.prevent_accidental_unloading = $.noop;

`


(Николай Ткачёв) #53

Please, post all script code


(Zashibis) #54

This one works:


(Daisy) #55

I’m seeing the timer again. I was using turbo, and I tried disabling it and installing the timer disabler script instead, but neither of them seem to be disabling the timer now. I tried looking at the script code & the page source, and it looks like the div container names haven’t changed, but my javascript skills are pretty much nonexistent and I’m stumped as to how to get it working again.

Anyone have any ideas as to how to get it working? I hate the timer - it’s a huge distraction.


(Zimorodokan) #56

use https://github.com/cooljingle/memrise-turbo/raw/master/MemriseTurbo.user.js


(Zurreal) #57

Yet another update… Does anyone know how to fix it?


(Aboose) #58

yup, both memrise turbo and disabler are broken as of today for me. anyone know a fix? these are crucial for me, really appreciate them.

edit: credits to cooljingle for this update:
This script will disable the timer:https://github.com/cooljingle/memrise-turbo/raw/master/MemriseTurbo.user.js
I would shift to this one as he seems to be maintaining it.


[Course Forum] Let's Learn Japanese course series (formerly SGJL)
(Firion) #59

Hmm I don’t like how turbo works beyond disabling the timer, it won’t auto detect the right answer when I input jp and am going through the suggestions, the going fast makes it feel glitchy to me even if it’s not.


(Shikami85 ) #60

I guess better than nothing @firion. Maybe cooljingle can make a script of just the time stopper.