Userscripts [e.g. Memrise Turbo and Memrise Timer Disabler] and some userstyles stopped working with today's web update

userscript

(Ang) #21

Thank you, it worked!!!


(Mimi ) #22

I’m still getting this and I can’t learn any longer :cold_sweat::sob:


(Gabriele Cramer Knebel2d) #23

I am getting the “Whoops” error too using Chrome since updating the scripts mentioned in the subject.


(Kim) #24

Thank you @Arete_Hime - even I was able to alter the timer disable script in Tampermonkey. I hate the timer as I am always distracted by others in the middle of typing.

@Maxine_Downunder - have you sorted it out? It really is quite easy (take it from a near-illiterate computer user).


(Maxine Downunder) #25

Not as yet @ripcurlgirl - I haven’t actually looked at it recently.


(Kim) #26

Do you access it through Tampermonkey?


(Maxine Downunder) #27

Hi @ripcurlgirl, I first set it up ages ago … I believe through Tapermonkey - which I assume is where one pastes the script provided. I’m not sure how to get back to that because I can’t find an icon for it.


(Kim) #28

I know you use a Mac. Do you access the internet with Chrome, Firefox or Safari?


(Maxine Downunder) #29

I use Chrome (9 times out of 10).


(Kim) #30

You can find the extension by clicking on the 3 stacked dots in the top right hand corner of the browser. Click on Settings. To the left you will find Extensions. Click on that and Find Tampermonkey an click on Options.

This will open Tampermonkey. Click on the tab “Installed userscripts” then click on “Memrise Timer Disabler”. Mine automatically opens on the script - it is located under the tab “Editor”.

Line 4 is the one I needed to alter - the full text is
// @match http://www.memrise.com/course//garden/ or
// @match http://www.memrise.com/*
[depending on which version you have on your computer]

you just need to place your cursor between http and : and type an s.

After that click on save (under the Editor tab are other tabs - it is the 2nd one from the left that looks like a floppy disk) and that’s it. Close Memrise and re-open and it should work.

It worked for me, I hope it does for you too :wink:

Bonne chance !


(Cooljingle) #31

Re-fixed the script (v0.0.22)


(Gabriele Cramer Knebel2d) #32

thank you @cooljingle, that code fix helped. I am not getting the “Whoops” error anymore.


(Kim) #33

@cooljingle Is this fix for Turbo? I didn’t have that installed before but I would like to install it now. Could you post a link to the updated userscript?

Merci !


(Maxine Downunder) #34

Hello @ripcurlgirl, I’m finally getting back to looking at this and thanks again for your instructions! I diligently followed your directions above (first 2 paras). When I clicked on “Installed userscripts” it did not take me to “Memrise Timer Disabler”, but rather to “Memrise Turbo”. This means I can’t see Line 4 which you refer to above and therefore can’t follow your remaining directions. Am I remedial or what? (Perhaps better not to answer that - LOL).


(Kim) #35

If you have Memrise Timer Disabler installed, it should be in the list. The fact that it takes you straight to the Turbo script leads me to think that that is the only script you have installed in Tampermonkey (but it should still display a list - of one in that case - to allow you to turn it off and on). That’s weird.

Mine looks like this:

Perhaps you installed it another way. Maybe try installing (re-installing?) it in Chrome through the original procedure here: http://userscripts-mirror.org/scripts/show/174879. Once it it installed, continue with the edit process.

Bonne chance !

EDIT Another direct link to the next version up is at https://greasyfork.org/scripts/3503-memrise-timer-disabler/code/Memrise%20Timer%20Disabler.user.js but it still needs the same edit (i.e. add the “s”) done to it.

Kim


(Cooljingle) #36

No, that was a reference to the Memrise Audio Provider script that had also been broken recently. Memrise Turbo isn’t my script, but you can manually do the same fix to it as you did with the Timer Disabler.


(Kim) #37

I know. I am responding to @Maxine_Downunder regarding the Memrise Timer Disabler script.

Cheers


(Kim) #38

Oops ! Igot a bit confused there :slight_smile:.

Unfortunately one course that I am taking that is without some audio is https://www.memrise.com/course/756657/verb-conjugations-en-francais/ and, when I apply your script, it says everything EXCEPT the word/phrase I want to hear. Try it for yourself from, say, Level 135. You will hear «être» au subjonctif en utilisant «il» but not the correct response (whether you type it in correctly or not). Which is a shame as I love this course.

Cheers

BTW @cooljingle, do you find that the Turbo script removes the ability to pause and save in the middle of a session?


(Cooljingle) #39

If you click ‘Audio Provider’ on the left while in the test screen you can change ‘Prompt’ to ‘Conjugation’ to switch to the correct column.

As for the turbo script, there is a line to disable the pause button:

MEMRISE.garden.pause = $.noop;

you can comment it out like so to bring the pause back

//MEMRISE.garden.pause = $.noop;

(Kim) #40

Merci cooljingle !

Il est très tard ici mais je vais l’essayer demain.

Kim