Userscripts [e.g. Memrise Turbo and Memrise Timer Disabler] and some userstyles stopped working with today's web update

userscript

(Ultra-Sadist Delinquent) #1

… because Memrise changed their urls from http to https

In your userscript or userstyle change the match accordingly to something like:

// @match          https://www.memrise.com/*

or perhaps

  // @match          *www.memrise.com/*

And they’ve probably changed some other stuff too. Feel free to edit this post (it’s a wiki) to add that.


How to turn the timer off?
Can I Turn off the question timer?
[Course Forum] SGJL series - Core 2k/6k Vocabulary Optimized by Charles_Applin35
Using memrise and other resources if you are blind
(Huntress) #2

Memrise Audio Provider also stopped working. I miss it very very much.

I changed http to https and the script activates, but it generates a mistake when submitting the answer:

“Whoops.
Uh-oh, something went wrong. Click OK to resume your session. (CSRF Verification Fail)”

and is totally unusable.


(Ultra-Sadist Delinquent) #3

Did you refresh first? Maybe a script like audio provider that fetches info from somewhere else fails more easily with https?


(Huntress) #4

Maybe. I refreshed everything I could. I really love this script and I really hope @cooljingle (the author) will fix it if he has time.

I use firefox. The script didn’t activate at all at first. Then I changed http to https in the “// @match” section and now it does activate, but generates the mistake I mentioned in my post above every time I hit enter when submitting the answer.


(Ang) #5

I have the same problem, it’s annoying! What can I do???


(Maxine Downunder) #6

I also have the same problem and realise as of now how used to it I’ve become. I also hope (as another user said) that @cooljingle can come to our rescue soon.


(poggi) #7

I opened the Add-ons menu in Firefox, changed the domain where the script works from http://www.memrise.com/* to http*://www.memrise.com/* and it works.


(Cooljingle) #8

script updated - should be all working now (v0.0.20)


(Maxine Downunder) #9

Hello @cooljingle, my Memrise Turbo is not working. I’m on a Mac and logged in via Chrome (Tapermonkey). Do I need to uninstall then reinstall? If so, I’ll need directions. Thank you!


Is there a way to stop the timer?
(Ultra-Sadist Delinquent) #10

This is not one of cooljingle’s scripts. You just need to change the match like I say in my opening post – so you need to find how to edit the script yourself. Here is the script.

// ==UserScript==
// @name           Memrise Turbo
// @namespace      https://github.com/infofarmer
// @description    Makes Memrise faster
// @match          https://www.memrise.com/course/*/garden/*
// @match          https://www.memrise.com/garden/review/*
// @version        0.1.4
// @updateURL      https://github.com/infofarmer/memrise-turbo/raw/master/MemriseTurbo.user.js
// @downloadURL    https://github.com/infofarmer/memrise-turbo/raw/master/MemriseTurbo.user.js
// @grant          none
// ==/UserScript==

var oldstart = MEMRISE.garden.feedback.start;
MEMRISE.garden.feedback.start = function (){
	if (MEMRISE.garden.box.state === 'choosing-mem') {
		oldstart(1);
	}else{
		MEMRISE.garden.box.next_press();
	}
};

$('body').on('keyup', function(e) {
	try {
		if ($(e.target).is('input')) {
			var g = MEMRISE.garden;
			var b = g.box;
			var s = g.scoring.score_response(
				b.$input.val(),b.thing,b.column_a,b.column_b);
			if (s === 1) {
				MEMRISE.garden.box.check();
			}
		}
	} catch (err) {
		console.log('error - falling back to default behavior', err);
	}
});

MEMRISE.audioPlayer.stop = $.noop;
MEMRISE.audioPlayer.stopAfter = $.noop;

(Beverly Johnsen59) #11

Changed as below but still not working for me. Have tried with and without adding and not adding @match line to (one or both) user settings> included pages and match pages, refreshed dashboard each time, timer still active in all configurations. I would try reinstall but all links I can find use old url and can’t be edited. Only thing I haven’t done is restart, but I’ve seen no mention of it in the discussions. I can usually figure out minor unfamiliar tech stuff on my own, but so far not this. Hope I’m missing something simple and obvious.

// ==UserScript==
// @name Memrise Timer Disabler
// @description Disables the Timer on watering & gardening levels in Memrise.com
// @match https://www.memrise.com/course//garden/
// @version 0.1.1
// @updateURL https://userscripts.org/scripts/source/174879.meta.js
// @downloadURL https://userscripts.org/scripts/source/174879.user.js
// @grant none
// ==/UserScript==

var onLoad = function($) {
$(“div.garden-timer div.txt”).bind(“DOMSubtreeModified”, function() {
MEMRISE.garden.timer.cancel();
});
};

var injectWithJQ = function(f) {
var script = document.createElement(‘script’);
script.textContent = ‘$(’ + f.toString() + ‘($));’;
document.body.appendChild(script);
};
injectWithJQ(onLoad);


(Ultra-Sadist Delinquent) #12
// ==UserScript==
// @name           Memrise Timer Disabler
// @description    Disables the Timer on watering & gardening levels in Memrise.com
// @match          https://www.memrise.com/*
// @version        0.1.2
// @grant          none
// @namespace https://greasyfork.org/users/3656
// ==/UserScript==
// Forked from http://userscripts-mirror.org/scripts/show/174879
// Corrected @match

var onLoad = function($) {
  $("div.garden-timer div.txt").bind("DOMSubtreeModified", function() {
    MEMRISE.garden.timer.cancel();
  });
};

var injectWithJQ = function(f) {
    var script = document.createElement('script');
    script.textContent = '$(' + f.toString() + '($));';
    document.body.appendChild(script);
};
injectWithJQ(onLoad);

(Beverly Johnsen59) #13

Worked! Thank you very much.


(Xephers) #14

I copied and pasted this to update the script, but it doesn’t seem to be working, the Memrise timer still turns on. It is possible I’ve done something wrong editing it since I don’t have much experience using user scripts with Tampermonkey.

Edit: Nevermind, I figured it out I wasn’t hitting the right button to save.


(Gabriele Cramer Knebel2d) #15

I can’t get Memrise Time Disabler script to work with Greasemonkey even copying and pasting the lines @Arete_Hime listed. I have restarted Firefox but the Timer is still coming on .From all the Memrise scripts I am using this Time Disabler script is the only one giving me problems.


(Ultra-Sadist Delinquent) #16

@GabrieleCramer-Knebe … then we can first try to rule out the obvious questions:

Is the script enabled and do you have only one copy of it?

Does this screenshot match what you see:

Does this screenshot match what you see:

If yes, I have no idea what could be the issue.


(Maxine Downunder) #17

Thank you @Arete_Hime, however “it’s all Greek to me”. I will seek additional IT help “on the ground”. Thanks again for providing the script though - I DO appreciated that.


(Mon Alyah) #18

Thank you @Arete_Hime.

My extension had this problem. It’s corrected. More fear than harm


(Beverly Johnsen59) #19

@GabrieleCramer-Knebe, did Greasemonkey tell you type “allow paste” at the bottom of the original script before pasting the new script over it?


(Gabriele Cramer Knebel2d) #20

Thank you all for your help. @Arete_Hime, it was all there as you showed it in the pics,but the timer was still enabled. And Ye, @BJohnsen it told me to “allow paste” before it would allow the new script to paste and be saved. Still Timer was not disabled.

I went back over all the text here and tried @poggi trick with the http*://www.memrise.com/* and strangely that works. Time is being disabled. Seems like it did not like the “s” on the “http:”, which is really weird. But then I don’t know much about programming. Maybe it’s time to learn it. :grimacing: