[Userscript] Memrise Audio Provider

userscript

(Yanan1935) #81

Hi thanks for the answer.No I am using Chrome. But i just tested something:
Spanish reviewing works fine
English words reviewing works fine
Japanese words with a course which has audio added = Freezes
Japanese words with a course without any audio = works fine
I really have no idea why it crashes.It crashes with Kanji (with added audio) and with Hiragana (added audio ) (katakana i think too )


Contribution to German course
(Roman Deu Ler) #82

Thank you so much! It indeed works now. Overrides old audios.
A small issue: sometimes the audio from TTS doesn’t play automatically, so I have to hover with the mouse over the speaker icon, so it starts playing the audio.
The issue comes up exactly when I go to the next word/card before the current audio finishes playing. In this case the next one won’t autoplay. Is there a way to fix this?


(Cooljingle) #83

I’ve tested on a couple of Japanese courses with and without audio and had no issues for learning sessions - maybe send me a link for a course where it’s freezing?


(Cooljingle) #84

I think I’ve fixed it (v0.1.21)


(Yanan1935) #85

Hi it freezes here :




Learning new words is no problem with the script but reviewing isn’t working.
A odd thing is
in the Genki 1 course It was possible to review 2 words till freeze
In the lingodeer 3
In the Tae Kims course 5
But if you have no problem than i think its maybe some other chrome addon or script which maybe interferes.


(Roman Deu Ler) #86

Thank you!
It’s better now. A more smooth learning experience now.


(Cooljingle) #87

I tried reviewing the lingodeer course and got through about 40 items with no errors - so I can’t say for sure why your sessions are freezing. If you want you can send me a private message with a screenshot of your console and I’ll see if there are any errors that can locate the problem.


(For S Sberg) #88

I’ve found issue - I reviewed 70 words and after more-less 40-50 the audio crashed. There was no menu for Audio Provider (on the left side) anymore.
I used RSS code but still heard Googles voice instead.

Generally it is still quite unstable addon or Memrise changes code too often.


(Cooljingle) #89

The menu option disappearing was something I’d put in so there would be some sort of visual indicator that the script was no longer trying to generate audio. This is probably happening for you because google limits how often you can call their tts service within a certain time period. I could maybe add local storage caching so that if you review the same words at a later time it won’t need to hit the tts service (I added caching for the current learning session but I guess it’s not enough for long review sessions).

I used RSS code but still heard Googles voice instead.

This is because voice rss audio is the lowest quality so google tts takes higher priority. If google tts fails then voice rss is used as a fallback.

Also worth noting is if the browser you are using supports speechSynthesis for your target language then this should be reliable as there isn’t a call limit, see here for a list of what’s supported in your browser.


(Huntress) #90

@cooljingle Greetings!

Oh grief! Oh sorrow! Something terrible has happened in our kingdom! Audio has stopped playing! Memrise update monster has attacked again and is now terrorizing peaceful citizens! People are hoping for a hero to come and save them!

Will patiently wait and hope that when you have time you will maybe fix the script again as it is absolutely awesome and it’s really very sad to have to use memrise without it. Thank you so much for supporting it.


(Cooljingle) #91

Yep, it’s happened again. I’ve fixed the script so should be working now (0.1.22).


(Nomad99) #92

Do you have, or do you know, any other alternative scripts that disable the timer? The one that I use with Tampermonkey hasn’t been updated for ages and it broke with this new update.


(Cooljingle) #93

This script will disable the timer: https://github.com/cooljingle/memrise-turbo/raw/master/MemriseTurbo.user.js


(Nomad99) #94

Awesome! Thanks!


(Aboose) #95

THANK YOU cooljingle. I will crosspost this.


(Kim) #96

This script still doesn’t work for me after the latest update. I’m wondering if it’s just me.

The dropdown list is empty and I can’t select any language. Maybe I’m just doing something wrong?

Naamloos


(Huntress) #97

For me the script works, but only starting with the second word in the session. For the first word I have a picture same as xKimka’s and the audio doesn’t play, but from the second word the script kicks into gear and everything is fine. I have even changed my usual setting of 10 words per session for 100 words to not miss the first word too often. I checked it both in Firefox (Tampermonkey) and Chrome (Tampermonkey) - it’s the same.

All praise our mighty hero and protector of the realm @cooljingle!


(Kim) #98

Ah yes, you are right! I didn’t even try to go further after the first word didn’t have any audio. But yes, from the 2nd word everything works fine again. :slight_smile:


(Cooljingle) #99

Great spot guys, I’ve updated the script to fix the issue (0.1.23).


(Q4) #100

Hi @cooljingle it seems that only these 2 particular courses audio can’t be played (the grey audio icon is added but when mouse is hovered over the icon and icon turns blue, no audio plays) I can’t figure out what’s the cause of this problem, is it only me? Audio is added for other courses though and works fine



I’m using Mac with Chrome 65.0.3325.162 and Tampermonkey v4.5
Thank you so much