[Userscript] Memrise Audio Provider

userscript

(Cooljingle) #41

Unfortunately I can’t reproduce your issue so I don’t know what the problem is :confused:


(Cooljingle) #42

I managed to reproduce the problem when using the autolearn script with this script, it’s due to some timing issue with the google tts calls. I have made an update which should hopefully suppress it from happening anymore (0.0.12).


(Casper Duo) #43

Thank you for your efforts.

I’ve something new happening now. I don’t seem to get the error message anymore, but the audio is lost suddenly and doesn’t come back. If I restart the session, after a few questions, it frequently happens again. This happens only in review sessions (blue reviews) as far as I noticed.

Scripts I use while encountering the bug:
memrise timer disabler,
memrise audio provider,
memrise all multiple choice,
memrise infinite learning

The course I am doing is this one: https://www.memrise.com/course/679217/5000-swedish-sentences/

Is it possible to put a check that if an error is thrown, in the following question the module will restart itself so you don’t have to restart the session?


(Casper Duo) #44

I will test this a bit more before rushing to a conclusion. I will report again in a few days.

P.S: I wasn’t using the auto-learn script at all.


(Huntress) #45

Hello, @cooljingle! Script version 0.1.12 stopped working in my firefox. When I enter a word it is not pronounced and the audio menu option on the left disappears. In chrome it is ok. 0.1.11 in firefox is also ok. So it’s ok, I’m just here to report it, so you would know.

p.s. Have I ever told you your script is awesome?


(Cooljingle) #46

Thanks for helping keep this script awesome, I wouldn’t have known your issue without you letting me know about it! Looks like firefox and chrome behave slightly differently (surprise surprise) which was why there was a problem… should be resolved in 0.1.14.

@Casper_duo - The update might help with your issue too, let me know if it’s fixed!


(Casper Duo) #47

@cooljingle I’ve the CSRF error again with the latest version.


(Cooljingle) #48

I made another update to try to fix it (0.1.15).


(Casper Duo) #49

Now we are back to audio lost but no CSRF error situation.
Checked under latest script version.


(Cooljingle) #50

Typically after how many words is it before the audio is lost? If you are doing many words quickly you may just be continually hitting google’s quotas for how many requests can be made over a period, which is something I can’t get around. You can use voice rss as a backup for swedish but this also has a limit (350 requests per day).


(Thomas Heiss) #51

Try to deactivate the “Memrise Turbo” user script.

You are probably typing much too fast; it really an enormous speed increasement using it and I couldn’t believe my eyes, once I installed/tested it on a 2nd PC when I compare how I review my PT BR DuoLingo course by MartinPen with Cooljingle’s “auto correct” script!


(Casper Duo) #52

Anywhere from 1 to 50, usually, less than 100.
What is weird is that I’ve no issue with the learning session, and i do the reviews the same way and with the same speed.
I would’ve said you are right otherwise. I indeed do them very quickly though. About 600 questions in 40 minutes.

Would it be possible to create a script to auto-upload tts voice to courses like the Awesome TTS script for Anki? https://ankiweb.net/shared/info/301952613

That would be the best solution.
There is no real need to hit the google api every time for the same thing, when you can do it just once for everyone.
TTS voice is usually much better than nothing.


(Casper Duo) #53

I don’t type or use the memrise turbo script. I do multiple choice questions.


(Cooljingle) #54

The tts requests are cached during the session so when you are learning the requests aren’t repeated when words reappear.


(Casper Duo) #55

@cooljingle That’s a bummer. Thank you for explaining. :confused:
I might have to move this deck over to anki then, and try to populate the audio there.

Here is a tutorial about the anki script I mentioned.
I marked the time frame.


(Cooljingle) #56

There is a similar tool for memrise that @DrewSSP created which could work for you:


(Kim) #57

@cooljingle

Merci beaucoup for this awesome userscript (v. 0.1.15) !

One of my favourite courses has 1/2 of the audio missing and this has solved my problem of having to go to Forvo or google translate to confirm the correct pronunciation.

Cheers,
Kim


(Kim) #58

@cooljingle cooljingle

This is a weird problem because I am using it on a course that only has about 1/2 the audio loaded (https://www.memrise.com/course/756657/verb-conjugations-en-francais/). I added the script after I had done almost 20% of it. The lessons were working a treat until it came to doing reviews (even of the parts that had audio) - they would not load while the your script was running. I wanted the extra audio so much that I cleared the course (had already done this to re-review before I found this script).
This has worked for me - so, thanks for the heads up (just wish I had read it earlier :rofl:

Cheers again,
Kim


(Huntress) #59

Hello, @cooljingle! Among other things that new memrise update has broken is unfortunately this awesome script. Even the option on the left doesn’t show up. As I think the update may have effected a lot of things and many of your scripts, I will only hope and patiently wait till you have time to fix it up.

Yours fan as always.

Update. Checked chrome. Chrome is Ok. Only in firefox the script has stopped working.

Update 2. Really sorry. False alarm. Now it is working fine both in firefox and chrome. (I downgraded my greasemonkey).

You are still the best.


(Kim) #60

@Huntress

What do you mean you “downgraded my greasemonkey”. Chrome is still playing up on revision even though I restarted the course. It is freezing after 1-2 revisions. I’ll try anything.