[Userscript] Memrise all typing

userscript

(Nojadrik) #82

I can confirm this issue too for the official Spanish courses.
My own (selfgenerated) courses still work.

I hate updates!


(Cooljingle) #83

Thanks for letting me know guys, looks like a lot of changes were made so a fix will require a bit of time. You can turn the script off until a fix is ready.


(Aurelien57) #84

I can say that the changes you had made for my Russian Cyrillic alphabet problems one month ago, aren’t valid anymore. The little " ’ " doesn’t appear anymore so the word isn’t recognised correct anymore neither. I’ll check this thread everyday to see if you manage to get a fix.

Thanks a lot for your work man ! Keep it up :slight_smile:


(Cooljingle) #85

I’ve submitted a fix, latest version is 0.1.24.


#86

Thanks for the fix but now I’ve got a bit of a image typing problem.


(Cooljingle) #87

Can you try depicting Alabama using Wingdings?

Just kidding :laughing: I’ve updated the script to not create those kinds of dodgy typing tests (v0.1.25).


(Aurelien57) #88

hey man thanks for your work and patience ! Just to let you know that the cyrillic thing still doesn’t work.

Before memrise did all their changes, i could see the " ’ " appearing on the cyrillic consonant as i just had typed the regular one, when the right word contained one.

For example if i typed “изучить”, the second " и " would transform into a " и́ " if the correct word was “изучи́ть”.

Good luck and thanks again mate :slight_smile:


(Nojadrik) #89

Yeah!! You made my day!

Thanks for your fine work!

I’m using memrise for roundabout 2 years, your script for two weeks now. And it makes all the difference. This boring typing is the only way to learn languages properly in my opinion!

So let’s hope, there’s no update in the next time. (fingers crossed).

Thanks a lot!!


(Kkeks) #90

Hey ! First Thanks a lot for all your hard work on the scripts, I love them so much!

Now the issue: I use both the “all typing” and the “audio provider” so I’m not sure where the problem is, but memrise constantly hangs when I get a word wrong. Could you please help?


(Thomas Heiss) #91

Tested with V0.1.25.
I was successful to disable “auto accept” as there is a bug for non-strict-typing courses to not work anymore without your “auto correct” user script.

Memrise seems to have something changed on Wednesday for their offical PT1-7 (tested 6+7) courses.
Usually they are configured as non-strict (all 1-6 + PT Basic).

The diacratics / accent keyboard for Portuguese is not shown for your actively converted multiple-choice and audio sentences anymore, as it did with older versions before the Memrise code update (this includes the re-typing 1st screen when giving the wrong answer).

HTML code:

<div class="keyboard clearfix" style="display: none;"></div>

For single words (originally typing):

<div class="keyboard clearfix"><a class="shiny-box">ã</a><a class="shiny-box">â</a><a class="shiny-box">á</a><a class="shiny-box">à</a><a class="shiny-box">é</a><a class="shiny-box">ê</a><a class="shiny-box">í</a><a class="shiny-box">ó</a><a class="shiny-box">õ</a><a class="shiny-box">ô</a><a class="shiny-box">ú</a><a class="shiny-box">ç</a></div>


Strict-typing breaks a course
(Thomas Heiss) #92

@kkeks This is an issue of the “audio provider” script V0.1.17, not because of “all typing”: [Userscript] Memrise Audio Provider


(Thomas Heiss) #93

This has nothing to do with “all typing”, but it is an issue of a non-compatible broken (non-updated) “auto correct” script with latest Memrise updates.

My Portuguese diacratics are also not back.
This is the pest with “auto accept” for offical Memrise courses or strict-typing user-created courses…


I think it is finally time to send some Paypal donations to Cooljingle because of all his hard work for the last 3+ Memrise updates…


(Cooljingle) #94

As Thomas was saying, there was an issue with the autocorrect script after the memrise update - this script has also been fixed now (v.0.0.12).


[Userscript] Memrise Autocorrect (diacritics, punctuation, case)
#95

Unfortunately I’m still having problems in courses with picture questions.

Could not pass this question even when I copied the “answer”.


(Cooljingle) #96

Should be fixed now (v0.1.26).


(Mimeslosydy) #97

Hi since a few days I am getting (almost only) tapping tests again when I’m learning new words (not during the review). The all typing script is enabled but shows a red exclamation point. Do more people have this problem?


(Thomas Heiss) #98

Why don’t you post the JS error message from the web console (F12)?

What are your settings for “all typing” on the left side?
Is the 3rd point “Include learning” activated?

Normally it is not, so the “Memrise standard” (mix multiple-choice + tapping + listen audio) is the default for learning new words.

I would probably get crazy if I had to type 6 times correctly a new word (including very new, weak, difficult), etc., so usually I do not activate the script for the first learning step; only 1(-2) typing (default) of 6 steps is IMHO enough.

BTW: You can deactivate “tapping tests” in your Memrise profile settings https://www.memrise.com/settings/learning/ if you do not like them.


(Mimeslosydy) #99

Oh thank you, I wasn’t aware of those settings. It’s fixed now. I’m used to all typing always, otherwise it feels too easy!


(Hjwold) #100

Hi. I started experiencing an issue today where a course (portuguese 7) freezes when learning new words. The next-button randomly stops working.

By the way, thanks so much for the script! You make Memrise so much better :slight_smile:


(Hjwold) #101

Seems to be working again…