[Userscript] Memrise all typing

userscript

(Cooljingle) #61

I’ve managed to load both courses on chrome and firefox… if you’ve already checked the script version the only other thing I can suggest is updating your browser if it’s particularly out of date.


#62

I use the latest Firefox and had no issues before. I just checked and now reviewing works again for both courses I mentioned but not for one of my own unfinished courses. Would it be coincidence that all the problematic courses contain pictures?


(Cooljingle) #63

Somehow I forgot to follow up your issue until today - sorry! I found the problem and updated the script to not break the session on those sorts of courses (v0.1.19).


#64

Thanks. The problem occurred intermittently but I had no issues today using the latest script.


(Swedeenz) #65

Having trouble today reviewing courses, seems to get stuck at the loading circle screen. Tried a browser without the script and it worked fine, and tried disabling script on chrome and it started working again. I’m on version 0.1.21. Anyone else getting stuck at the loading screen?


(Javaugy11111) #66

Same problem here. Worked this morning. Not this evening.


(The Four Gated Danzig) #67

Yeah, I left a message for Mr. Jingle earlier. An update with Memrise must have messed it up.


(Zimorodokan) #68

Same problem.
FF56
version 0.1.21

TypeError: can’t convert undefined to object classic_review:175:28
MEMRISE.garden.populateLearnables/< https://www.memrise.com/course/332202/12527/garden/classic_review/:175:28
anonymous/< https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-0b0009b612.js%20line%204%20>%20Function:20:5
rn https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-0b0009b612.js:4:12151
MEMRISE.garden.populateLearnables https://www.memrise.com/course/332202/12527/garden/classic_review/:174:9
MEMRISE.garden.boxes.load</< https://www.memrise.com/course/332202/12527/garden/classic_review/:101:13
session_start garden-base.js:150
success garden-base.js:66
u https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-0b0009b612.js:2:16782
fireWith https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-0b0009b612.js:2:17558
i https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-0b0009b612.js:3:21278
n/< https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-0b0009b612.js:3:26129
i https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-0b0009b612.js:15:2590


(Premonition) #69

Yep, using it on Chrome and it’s been breaking for me too.


(08ovij) #70

I am getting the same problem as well, hopefully it will get fixed shortly!


(Cooljingle) #71

Thanks for letting me know guys; latest script should now be working (0.1.22).


(Autismal) #73

To anyone else encountering issues with the unsolicited Firefox update breaking Greasemonkey: I replaced it with Tampermonkey and reinstalled the script, and it works fine.


(Aurelien57) #74

Hi, first of all thanks hugely for the that script which is definitely a game changer, because i think the most efficient way to learn for me is by typing words.

I just installed the script and unfortunately i have a problem. I’m learning Russian and one of the courses i focus on the most is this one : https://www.memrise.com/course/879780/verbes-russes/

The creator of this course put a " ’ " above the stressed vowel in the word, which indicates how the vowel should be pronounced (ex: и́ я́ а́ ы́ е́ у́ о́). Obviously these signs are absent in the real language and и́ я́ а́ ы́ е́ у́ о́ become и я а ы е у о. So i’d like to know if there’s a way to make the script accept “и” instead of “и́” and the same for other vowels, so the script doesn’t deny the word i typed ?

So i can type “видеть” instead of “ви́деть” and still the script will accept my word ?

Thanks a lot ! :slight_smile:


[Userscript] Memrise Autocorrect (diacritics, punctuation, case)
(Thomas Heiss) #75

Yes, add the user script “Auto correct”.

This even works for strict-typing configured courses, like my Portuguese BR course, with all the special characters.
I type without any accents, because of time and missing keyboards, and the script auto-changes the letters to the correct ones.

There is nothing which needs to be changed in “all typing”, if you use both of them at the same time.


(Aurelien57) #76

I tried it but it doesn’t work, i checked out the source code of auto-correct and it doesn’t have cases with the cyrillic alphabet, i tried adding 3 characters following the previous pattern by adding :

{‘base’:‘и́’,‘letters’:/[\u0438]/g},
{‘base’:‘я́’,‘letters’:/[\u044F]/g},
{‘base’:‘а́’,‘letters’:/[\u0430]/g},

The unicodes are good, but the problem comes from the little " ’ " above the letters (ex: и́), because it’s a combination of 2 uni-code characters according to graphemica.com, so the script probably doesn’t even know what it is itself.

I’m not good enough in programming to fix that so if the author would give it a try that’d be awesome ! Thanks :slight_smile:


[Userscript] Memrise Autocorrect (diacritics, punctuation, case)
(Cooljingle) #77

I’ve updated the autocorrect script to address your issue (0.0.11).


(Aurelien57) #78

I just tested it and it works perfectly ! I can’t thank you enough, it’s now super convenient to learn because i don’t like tapping questions. You’re really talented ! Have a great one :slight_smile:


(Kalrm) #79

It stopped working for me, for some reason. Anyone else?

I really like this script. I don’t feel like I learn anything with the multiple choice.


(Sgomarteli) #80

Same for me. I’ve tried reinstalling the script and also made sure all the boxes were checked on the “All Typing Settings.”


(Thomas Heiss) #81

Hi @cooljingle,

the last Memrise code update from Wesnesday 01/17/2018 fucked up your all typing script V0.1.23.
Tested with Firefox V52.5.3 esr with Greasemonkey V3.17.

TypeError: o is undefined[Weitere Informationen]  garden-bundle-94009e949c13.js:1:284712
	[1]</</c.ThingBox<.get_context https://d2rhekw5qr4gcj.cloudfront.net/garden/dist/js/garden-bundle-94009e949c13.js:1:284712
	Class</<.inherit/r https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-41c582fa7c13.js:1:269317
	[1]</</c.TestBox<.get_context https://d2rhekw5qr4gcj.cloudfront.net/garden/dist/js/garden-bundle-94009e949c13.js:1:288172
	Class</<.inherit/r https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-41c582fa7c13.js:1:269317
	[1]</</c.Box<.render https://d2rhekw5qr4gcj.cloudfront.net/garden/dist/js/garden-bundle-94009e949c13.js:1:281515
	[1]</</c.Box<.activate https://d2rhekw5qr4gcj.cloudfront.net/garden/dist/js/garden-bundle-94009e949c13.js:1:281154
	[1]</</c.ThingBox<.activate https://d2rhekw5qr4gcj.cloudfront.net/garden/dist/js/garden-bundle-94009e949c13.js:1:283301
	Class</<.inherit/r https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-41c582fa7c13.js:1:269317
	[1]</</c.TestBox<.activate https://d2rhekw5qr4gcj.cloudfront.net/garden/dist/js/garden-bundle-94009e949c13.js:1:288779
	Class</<.inherit/r https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-41c582fa7c13.js:1:269317
	[10]</f<.activate https://d2rhekw5qr4gcj.cloudfront.net/garden/dist/js/garden-bundle-94009e949c13.js:1:384723
	Class</<.inherit/r https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-41c582fa7c13.js:1:269317
	[1]</</s<.activate_box https://d2rhekw5qr4gcj.cloudfront.net/garden/dist/js/garden-bundle-94009e949c13.js:1:291486
	[1]</</s<.begin https://d2rhekw5qr4gcj.cloudfront.net/garden/dist/js/garden-bundle-94009e949c13.js:1:291201
	[1]</</<.session_start https://d2rhekw5qr4gcj.cloudfront.net/garden/dist/js/garden-bundle-94009e949c13.js:1:22066
	[1]</</<.load_session/<.success https://d2rhekw5qr4gcj.cloudfront.net/garden/dist/js/garden-bundle-94009e949c13.js:1:19961
	at.Callbacks/l https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-41c582fa7c13.js:1:36968
	at.Callbacks/u.fireWith https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-41c582fa7c13.js:1:37739
	i https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-41c582fa7c13.js:1:75655
	.send/n/< https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-41c582fa7c13.js:1:80514
	i https://d2rhekw5qr4gcj.cloudfront.net/dist/js/libs-41c582fa7c13.js:1:439737

Either the PT6 BR or PT7 BR courses freeze on review load (no question and typing box shown) or stop working after a few questions (no next question after the last has been answered):