[Userscript] Memrise all typing

userscript

(Cooljingle) #41

Thanks for letting me know - I just updated it to ignore case also (0.1.11).


(Wtjiv) #42

@cooljingle awesome. also did you see this PR? https://github.com/cooljingle/memrise-all-typing/pull/3


(Cooljingle) #43

just spotted it :+1:


(The Four Gated Danzig) #44

I just tried a learning session. I get the audio as link as per screenshot above, and I get strict typing.

And just tried a review. Not kicking me off, but is doing the audio-link and strict typing.


(Wtjiv) #45

@cooljingle one more issue then we’re good to go! sorry this is on me
https://github.com/cooljingle/memrise-all-typing/issues/4


(Cooljingle) #46

Thanks, I realised I hadn’t set my test columns properly. Both the punctuation and the audio test issues are resolved (0.1.13)


(Wtjiv) #47

New issue to report - here’s a screenshot
Let me know if/how I can help


(Cooljingle) #48

thanks - should be fixed in the latest update (0.1.14).

Additionally, for those who have strict typing enforced it should be accepting your punctuated answers now.


(Swedeenz) #49

Thanks for the fixes Cooljungle, more or less back to normal for me!


(Piknyc) #50

I’m still have some issues. My answers are being rejected but they are correct. Additionally there is no highlighting of the mistake on the review page.


(Cooljingle) #51

I think you might still be on the older version of the script, maybe try to update? Latest version is 0.1.14


(Cooljingle) #52

Alternates seem to be working now too :raised_hands:


(Cooljingle) #53

I think I found the problem! You’ll need to update to 0.1.15…

Basically some sentences are using ‘no-break spaces’ - they look like spaces but they actually are a different character :confounded:

I’ve updated the script to it replace them with normal spaces, so the checks should pass normally.

@swedeenz @mimeslosydy this may have been affecting you guys too.


(Sbranfarrier27) #54


(Cooljingle) #55

found it thanks, try updating to 0.1.16


(Mimeslosydy) #56

It seems to be working well again, thank you


(Wtjiv) #57

Hey @cooljingle, there’s another small issue - entries like this ты (тебя; тебе; тобой) are now requiring me to type all the grammatical forms. In the past I could just type ты and it would evaluate to correct, which I prefer. Any idea what’s up?


#58

Yep, I’m getting this too. I’m on version 0.1.16. Here’s an example of one I got a ‘red’ wrong for during review:

I’m getting a red wrong for “demasiado” and for “demasiado (demasiada)” but it accepts “demasiado, demasiada”.


(Cooljingle) #59

I’ve updated the script to handle brackets and semicolons as alternatives, latest is 0.1.17.


#60

Two days ago I started having trouble with reviewing some courses and not others. Since yesterday I couldn’t review this course. The garden was just stuck on loading. Today the garden of another course was also not loading until I disabled your script. So the last update seems to break something.