[Userscript] Memrise all typing

userscript

(Dupens) #21

@cooljingle thank you for this script! This is absolute game changer for me! If there is something that you would like me to contribute for you regarding this (and possibly other memrise) script on github, just ask! I’m willing to help:)


(Jae Mon21) #22

Thank you so much for this script. I’ve been using it for a few weeks now and it is the main reason why I switched back to Memrise after using Anki. I’m not a fan of typing and really don’t have the time to be creating all my own courses. This allows me to use (and enjoy) every course on Memrise, not just the small number that offer no typing.

It would be cool if Memrise offered this as a normal feature/option, but very happy that someone is willing to create and maintain a userscript. Thanks again! :slight_smile:


(Huntress) #23

Hello, @cooljingle. I am a fan of your scripts and today decided to try “Memrise all typing”. My problem is that my course has both typing and multiple choice levels. And my dream was to somehow enable the script only for typing tests (e.g. to type when you make a mistake) and leave multiple choice as it was (typing is checked off for the column in the database). As I studied the settings of your script I thought that theoretically it was possible and “Include Mistake Reviews” checkbox was just what I needed. So I checked off all the other checkboxes (especially checked off “Include Typing Disabled”). And I’m still prompted typing for everything including the words I previously had only multiple choice. I tried checking off all of the checkboxes completely and I still am asked to type in multiple choice levels. I use my personal course. I tried that both in firefox and chrome (Win 7). It’s the same. Am I doing something wrong? I know that these are only my personal unconventional needs but the settings made me think that it should work. Sorry to bother.

p.s. Love your scripts.


(Cooljingle) #24

The script behaviour should match what you say you were expecting - I took a quick look and I haven’t found an issue with the logic; can you check that your multiple choice levels have typing switched off on the Testing on column (it’s this, not the Prompt column, which decides if typing is enabled/disabled).


(Huntress) #25

Thank you for a fast reply. Yes, typing is definitely switched off.
I have a level where settings are “Test on Russian, prompt with English.” In “Testing” tab of “Russian” column typing and tapping are switched off.

It is not shown on a screenshot, but these are options for “Russian” column. Being paranoid and just in case I switched off typing for all the columns. And with scripts turned off I get a multiple choice test.

Then I turn on the script and check only “Include Mistake Reviews” checkbox.

And then I get only typing tests for this level.

I tried my other multiple choice course and it’s the same there. Only typing.

But thank you all the same. Your scripts are awesome.


(Cooljingle) #26

I think I found the problem, try updating to 0.1.8


(Huntress) #27

Thank you so much! It works! You are the best!


(Cooljingle) #28

I made more fixes after recent Memrise changes - let me know if you find any issues (latest is 0.1.9)


(The Four Gated Danzig) #29

Haven’t tested it yet, but you da bomb.

@cooljingle, k. So I’m getting this error.

Now I have to click on the link to play the audio, but at least the typing is enabled lol.

It also somehow made it strict typing. Before I didn’t need to include commas or periods, but now I’m getting answers marked yellow without them.


(Piknyc) #30

Thanks for the update, but now it appears all my typing answers are incorrect. And I’m having the same issue with the commas as mentioned above.


(Swedeenz) #31

Hey, on chrome. Started having issues today for the first time, reviewing words starting going weird, telling me that the correct answers were incorrect, and instead of just typing tests, audio and multi-choice questions have appeared while reviewing.


(Cooljingle) #32

Multiple choice coming back should have been fixed in my last update - perhaps check you’ve updated the script to 0.1.9?

I’m yet to confirm if the issues with strict typing only happen with the script on - if someone could let me know I’d appreciate that.


(Huntress) #33

I have the same problem as on TheFour-GatedDanzig’s screenshot but with images. Instead of the picture I’m getting the link to the picture. When I turned off the script the image showed up correctly. Interesting thing that it isn’t the problem on all the courses. Most courses with pictures I have were ok even with the script on, so it’s probably will be hard to track it. (hypothesis based on very few courses: it only happens to the courses with original multiple choice options, original typing tests are ok, but I’m not really sure, just a guess).

The problem with converting multiple choice tests to typing even with “Include Typing Disabled” option unchecked came back. I have only “Include Mistake Reviews” option enabled, but since the new update I get all typing tests even where typing is disabled and I originally had multiple choice.

My current script version is 0.1.9.


(The Four Gated Danzig) #34

Right. I just went to Tampermonkey’s dashboard, turned all typing off, and now I can do the sentences. However, it’s in the standard Memrise way of reading the audio, and I have 8 multiple choice options to match the sentence, which is exactly what I’m avoiding.

If I turn the script back on, I get the link to the audio in addition to the weird feature of now strict typing with no avoidance of commas and periods. I don’t really get what Memrise did yesterday.


#35

@cooljingle, thanks for your fixes today! I’m still noticing one thing, though. With the ‘all typing’ script turned on, it’s now requiring exact typing, including punctuation. For example, I have just been marked incorrect for omitting an elipse from the end of an item.


(Swedeenz) #36

Hey, yes I have 0.1.9 running. I tried running on a browser without the script and everything works fine, so it seems to be the script causing issues.


(Cooljingle) #37

I’ve updated the script (0.1.10) to address both the strict typing and the audio links. If there are other glaring issues still about please let me know.

At the moment there are still a couple of minor annoyances; hopefully they shouldn’t be too much of an inconvenience. They occur if the item does not have a typing test and requires the script to make one for it.

  • alternate answers won’t work - hopefully there will be a way to get these in the future but at the moment the data for it isn’t there. (fixed after memrise update)
  • no strict typing - if you want strict typing you won’t get it as the punctuation will be ignored (fixed 0.1.14)
  • no typing aid buttons - the accent buttons won’t appear

(The Four Gated Danzig) #38

K, @cooljingle I just tested it again with my Japanese course. I still get the same as my screenshot above: the link to the audio. Also, when I typed in the answer, I got a whoops, error message and was shoved off of the session.

edit: oddly enough, it also didn’t save my having typed the answer. I just got the sentence again.


(Wtjiv) #39

@cooljingle - thanks for the update tonight, it fixes the ellipses, etc. But I did find another issue, for some reason capital letters after a space aren’t working. In the past it was not case-sensitive; now it not only complains about the lowercase а but does not recognize the uppercase А.

Here’s a screenshot:


(Cooljingle) #40

I still need to reproduce it for myself - do these come up during review, when you make a mistake or during learning?