[Userscript] Memrise all typing

userscript

(Cooljingle) #1

Thought I’d create a new forum thread for this to replace the old dead one.

Readme: https://github.com/cooljingle/memrise-all-typing/blob/master/README.md
Old thread: http://web.archive.org/web/20160508163822/http://www.memrise.com/thread/1364557/

latest version (v0.1.3) should have the fix for the memrise switch to https; I’ve also turned all typing enforcements on by default as most people seem to set it that way and then get confused every time a script update comes and changes it back.


Switch a course to/from typing or tapping?
How to turn off a function
Suggestion: provide option for typing-only translation questions (no unwanted hints)
Not allowing typing questions
Course 3 - changing in the Review
[Course Forum] French 1-7 by Memrise
Typing course, coming up with picture multiple choice
Disabling Typing Tests
Only the multiple choice option is provided for phrases longer than four words!
Memrise learning Mode
How do I deselect multiple choice questions, and make it text/writing only?
Classic Review
Is there a way to disable word selection tests?
Insane Overlord (In a good way)
Reduce eye work / how can i better watch tv when doing memrise
(Autismal) #2

This is working very well with this change, thanks a lot to you both.


(Kaspian) #3

@cooljingle - Thanks for quickly updating this script and all the others that you’ve written!


(Eneej) #4

Hello. Ceased to operate your script - Memrise all typing. Help fix it.


(Cooljingle) #5

Just to comment on what that change does - it enforces typing even if the column being tested has been specially set to no typing.

If you like I can add it as part of the options at the top of the script, although I’ll probably set it to false by default.

Another thing I should get round to doing is storing preferences locally so if the script gets updated down the line people’s settings stay intact.

@eneej - check the version of the script you are running, latest version 0.1.3 should be working.


#6

Just installed this into Firefox. First test I still got multiple choice questions for the sentences.


(Neoncube) #7

Have you updated to the version that cooljingle just posted?


(Eneej) #8

Make changes in the script Memrise Turbo. Replace the protocol http to
https


(Zil) #9

This is working really well for me now, (although only with the change linked to by autismal).

Many thanks


#10

Hi @cooljingle,

I added the Memrise-all-typing script (v0.1.3) direct from the link in your OP in this thread and the Tampermonkey icon displays it is ‘turned on’ when I am reviewing Memrise-created courses but I am still not getting typing tests for phrases (only tapping tests and MC).

Was there something else I needed to do?

Thanks!


[Course Forum] French 1-7 by Memrise
(Mishamus) #11

Hi @alanh, I got this working today on Firefox on a PC Windows 10. There is a small change you need to make to the js in cooljingle’s repository. It is explained here: Not allowing typing questions.


#12

Hi @Mishamus,

Thanks! Do you know if that will work for Chrome, too?

If so, I’ll take a look later when I have more time. I’m very much a novice when it comes to user scripts. :persevere:


#13

Yes, with that change it is working for me too.


#14

Hi @Mishamus,

I have now got this working on my laptop using Chrome. :smile: It took me a couple of attempts but it’s such a relief to have my typing tests back! Thank you so much!

Many thanks to @cooljingle, too! :clap:

If only we didn’t have to add scripts to make something work properly again!


(Memrisesteph) #15

this script is so wonderful!!! thank you!!


(Cooljingle) #16

There was a another recent change whereby items in the official courses with over 15 characters had typing questions turned off, this may be a reason why so many people had been getting multiple choice even with the script turned on.

I incorporated the change linked by autismal in an update, along with adding a link on the left when in a learning session - ‘All Typing Settings’ that you can use if you want to change from the default (which is to turn typing on in all scenarios) - the changes to these settings are saved locally so if the script needs a further update you won’t have to fiddle with the settings again.

latest is 0.1.4


(Espiacent) #17

Sorry, this post can be deleted. Double post.


(Espiacent) #18

Thanks for the script. Is there a way to integrate this in Safari? I know I could simply use Firefox (which I use for Wanikani) but for Memrise the experience always was better with Safari somehow.

Edit: Sorry, I forgot about Tampermonkey …


(Cooljingle) #19

I didn’t know that there was a Tampermonkey for Safari - if it works then great! There’s a Tampermonkey for Firefox also, which may be a bit more user friendly than Greasemonkey. I tend to use chrome where it works fine for me.


(Espiacent) #20

I didn’t know there was Tamperamonkey at all. All I knew was Greasemonkey for Firefox (which I use as well). But anyway: The script works with Tampermonkey without problems in Safari. Thanks!