[Userscript] Attempt to Eliminate Phantom Entries

Thanks for your help! :slight_smile:

You’re welcome :slight_smile:

Let me know if you run into any issues.

1 Like

This worked great! Thanks again!:grin:

Glad to hear it, and you’re welcome :slight_smile: I’ve had fun writing some of these scripts.

Your script works well, thanks very much for sharing it.
I’ve used it on four courses, about 3000 words total. About one in a hundred words does not turn green but grey. Does the grey mean anything?

You’re welcome :slight_smile:

Entries are marked as gray when they already appeared in an earlier level in the course. This can actually be a good way to tell when you’re teaching the same item more than once in a course, although that wasn’t my intent :slight_smile:


That is a useful feature (although some of the double entries I had were intentional).
And because all levels are unfolded in the process you can actually search for a word in all levels at once. :slightly_smiling_face:

Haha, ya, the script ended up having some nice, unintentional side effects :slight_smile:

I use chrome and all phantom entries have disappeared on the pc, with a smartphone all entries with an erased stress remain, for example: сы́плю —> сыплю both words pop up at the same time and one needs to know he has to choose the one without the stress.



Are you sure that the course has been totally refreshed on the app? If you’re using it in offline mode, can you try deleting the course from the phone and redownloading it?

I use it only online and I refresh it every time I make a change. plus all courses on the app give only one option on the answers, in theory all the words have the “no stress” option, but the app seems to ignore it. with the new courses I have learned not to stress words and not to insert options and everything is fine. the important thing is that erased words won’t show up any more.
I might give you a screen shot if you like.

Ah, I have an idea. Can you go into your course’s database and see if there are two entries, one with the stress and one without? I think that might cause this type of issue.

If that’s not the case, then ya, a screenshot might help :slight_smile:

I have painstakingly removed all the entries with a stress, 1200 of them. I will provide you with a screenshot as soon as I can.

here’s the screenshot
ждàвший and ждàвши shouldn’t be there, I erased them a long time ago.

hi, everybody.
just tried the script with greasemonkey using firefox 55.0.3 (64-bit) in arch linux and everything worked great.

thanks a lot to Eli for the script :bowing_man:.

1 Like

You’re welcome!

Glad it worked :slight_smile:

@acnalbasac, sorry, I kind of forgot about your post.

It looks like postimg.org is blocked in China, where I am, so I’m unable to view your screenshot. There’s an “upload” button when posting; could you please try to upload the screenshot that way?

Can you please post a link to the course where this is happening, too?


this is from the desktop version: 6 and 7 are exactly the same, there was a copy which I deleted but it keeps showing up

this is the course

by the way, in the app the option answer doesn’t work, the option I type in will only show as a gosth entry and marked as wrong if I choose it. so now, in my new courses, no option answers, no stresses and I carefully avoid double entries and everything works perfectly.

this one is very difficult to do on a smartphone because the option answers just don’t work:

Yesterday the script stopped working for me. :slightly_frowning_face:
Now it only the unfolds the levels and then nothing happens.

Okay, this should be fixed. Thanks for the bug report :slight_smile: