Typing tests not being offered when expected on ios

I am using a third party course which uses typing tests using the web interface, but on the IOS app I get either “pick the right one” or “rearrange the words” depending on the app learning settings, but never typing tests.
I consider this a bug.

I am also learning a course set to typing only within the course (created by myself). If I have the IOS app setting set to enable tapping tests, the course expects typing, as intended. If I turn off tapping tests in the app setting, the supposedly typing only course changes to requiring me to select from multiple options all the time and no longer offers any typing tests. This course also works as expected when using the web interface.
This latter part may perhaps be considered as bug with the setting name and help text, but I suspect it is relevant to the problem using the third party course,

Ipad Air 4th gen
Ipad os 14.7.1
V 2021.7.26.40287

Hi, thanks for reporting this.

Have you already tried uninstalling the app, restarting your device and reinstalling it?

If the issue persists after the steps above, please confirm the names of the courses this occurs with so we can take a look.


1 Like

Thanks for getting back to me so quickly.
I did the uninstall, shutdown , reinstall, still the same.
I tried:
my typing only courses: 50 most important Latin verbs with macrons - Memrise
and JACT Ch1-9 Adjectives - Memrise (this one is Ancient Greek)
I also tried the Memrise course German 1 - level 10 vocab booster more numbers - the effect was very apparent in review mode.