Typing strictly on accents, not on apostrophes (Mac)

Don’t know if this is related to the transition to decks, but I found today that my self-generated French course was no longer being strict about requiring accents. So, I edited the database for my course to select “Mark Typing Strictly”. But I then found that it no longer liked my response for entries with apostrophes. Apparently on my Mac keyboard
what I thought was an apostrophe (’) is actually a single quote (’). From googling I see that I can type “Option + Shift + ]”, but that’s a bit of a pain.

The French words/expressions in my course are all copied/pasted from words in newspaper articles I’ve been reading, so they have “real” apostrophes in them.

Is there some way to require correct accented characters to be entered, but to allow a single quote to be treated as an apostrophe?
(I had the feeling it was indeed working like this until the transition to decks today, but maybe I’m wrong…)


I don’t think so. A rather tedious option is to put in all the “alternative answers” - the same answers with single quotation marks instead of apostrophes.

If I was going to do that I guess it’d be easier just to change the apostrophes to single quotes anyway - is there a global change function for the database editor by any chance?

This post was flagged by the community and is temporarily hidden.