Stuck on Course 5, new course won’t load

I’m starting to use Memrise less, because I’ve been stuck in Course 5 for weeks now, no matter how often I was using it, no matter how well I progressed. I’ve begun thinking it’s a glitch. Unless there’s something I’m not understanding about how to move on.

Any pointers much appreciated.

Obrigado . . .

That sounds annoying!

I have just tried loading that course and it worked OK for me on both the web version and on the android app by selecting it from the course list on each. Which platform are you using? Is it only that one course which will not load for you? Have you tried selecting any others?


For the most part I use the iOS App on my iPad, though I also occasionally use the website. In both places, I have completed Courses 1 through 5 of European Portuguese, with no new course offered or on display anywhere. Attaching a screenshot of what I see on my home screen.

1 Like

To access the course list on the web version (your screenshot) click on “Courses” in the black bar at the top, then on “Languages” in the “All categories” panel on the left. Then click on “European”. You should then see “Portuguese (Portugal)”, and that will get you to your course No 6.

On the iOS app, tap on the yellow “Learn another course” bar at the bottom of your home page. Then tap on “Portuguese (Portugal)” and then on “Browse more courses”.

Good luck!


Thanks so much!

I was confused by the term, “course,” which means both the entire course of a language, and the individual level. So when I went to “course” to select a new level, and saw only a list of languages, I stopped looking.

That, and the fact that once I’ve completed a course (level) before, I’ve been automatically shuttled along to the next one. For whatever reason, this didn’t happen when I completed level 5.

Anyway, your answer has solved my problem.

Muitissimo obrigado!