Still experiencing problems editing mid session

Hello
I raised this earlier, and you responded with a fix, and I confirmed it was working.
However, it seems that there are still problems editing mid-session.
It seems like I can edit the English answer text (although that can take several attempts to find the sweet spot), but I find it impossible to edit the foreign language text. No matter where I tap (and believe me I’ve tried all over the place) the general pop-up comes up instead of landing me in the text so I can edit. I summise that the screen area where I am supposed to tap must be either miniscule, or non-existent.
I am using Firefox for android on a Samsung Galaxy Tab4. All software is up to date.
Hope you can help
Regards
Mishamus

Hi, thanks for reporting this. It sounds like the issue might be caused by the fact that you’re editing your course on a mobile device/browser. Please note that our course creation functionalities are optimised for laptops/PCs, not for mobile devices.

Nonetheless, please try the following steps to see if it helps:

  • Please make sure AdBlock, AdBlocking technology or Ghostery have been disabled
  • Clear cache and cookies
  • Disable any active extensions and/or userscripts
  • Ensure your browser is updated, and restart it
  • Can you try loading the session in Google Chrome?
  • If Chrome fails, can you try loading the session in incognito mode?

If all of the above fails, please let us know of the outcome and provide screenshots/steps to reproduce the bug. Videos/GIFs of the problem will also help us investigate more easily.

Please also confirm which course(s), level(s), learning modes or section(s) of the website this occurs with.

Thanks

1 Like

Hi Alessio

Thanks for responding.

I do get it that you can‘t make your system work for every variation of hardware/software. However, from my side, I can say that I have been using Memrise for years via a browser on an android device. And for the majority of that time it‘s been Firefox – which is surely not a corner-case browser. So it‘s frustrating to find issues popping up seemingly from nowhere.

This combination – the browser instead of the app and Firefox as the browser, is essential to me for just one reason – it‘s the only way I can make use of the userscript that forces typed answers, and I am not exaggerating when I state that being able to do that is the only reason that I continue to use Memrise (and pay for premium).

Having said all that – I suspect that the problem is partly with Firefox for Android. They released a new version not so long ago and it‘s quite different. As you suggested, I tried the same scenario in Google Chrome and it works fine there. However, Google Chrome is no good to me since it does not support user scripts. So I‘m stuck it seems.

Meanwhile I have done some more testing and found these points. The issue is that the ‘edit column’ pop up appears when trying to edit the text in the field.

· The issue is not just editing during a session. The same issue occurs when editing the course in the normal way.

· The issue occurs only on courses that have levels, therefore a ‘database’, which is used to search and edit

· It occurs only on text in the top line – hence the problem editing during a learning session. This leads me to conclude that it‘s something to do with the real estate assigned to the column headings.

Here are some technical details:

  • Firefox 81.1.5 (Build #2015769595) AC: 57.0.8, 5653ef5fd GV: 81.0.2-20201012085804 AS: 61.0.13
  • Samsung Galaxy Tab S4 – model SM-T830, running Android 10, One UI version 2.1
  • Sample course – Íslenskir Afleggjarar

You may not want to pursue this, which I understand. Not being able to edit on the fly is not a show-stopper for me. I can save up any edits for when I power up the PC. The loss of the ‘all typing’ userscript however, would be a show-stopper.

Regards

Catherine

Unfortunately I’m afraid the team won’t be able to address this issue as it has a very low priority against other fixes and improvements, however we do appreciate the detailed information about your device and software - they will come in handy should we decide to look into this in the future. In the meanwhile, please edit the course on a PC.

You might also be interested in or ‘typing only’ course setting - more info in this article.

Thanks for understanding.

1 Like