Some possible answers include both the target and base language terms

Hi guys,

I’ve noticed that during practice some of the multiple-choice options include the target language but also the base language, which kind of defeats the purpose of the exercise.

It does not happen with every term though. Here’s a video I shot to best explain the issue: New Recording - 10/08/2023, 13:24:37

Any ideas?
Thanks in advance

What you’re describing is the so-called “phantom entries” problem.
You’ll find more information as well as a possible remedy in this thread:

Note that, in order to apply the script, you need to either be the course creator or a contributor.
If you’d provide a link to the course we could check as to whether the creator is here on the forums. If not, you can → apply to become a contributor to the course.

FWIW, it always makes sense to provide a link to the course in question.

1 Like

Thanks for your reply. Really quick :grin:

However, I’m not sure these are Phantom Entries. The description of Phantom Entries in that forum is “sometimes when you’re presented with multiple choice answers, some of the answers will be old definitions that aren’t present in your course anymore. These are phantom entries.”

That is not the case. What is happening here is that what is displayed is both the Portugues and it’s english translation. All in the same option.

In fact, when I ran that script, it did nothing (as fas as I can see from further testing)

Hope that makes sense.

Sorry, this is the course in question: Pre-Journey - The One With The Benfica … - by portuguesewithcarla - Memrise

So you’re the course creator, that’s good. :slight_smile:

As for the “why is this happening”: when you edit & save an item (word, phrase, etc.) within your course, the system assembles a list of items that are being presented in MPC tests. That is, it takes other then existing items and adds them to that list.
If you then go ahead and edit/change or delete one of the items that is found on the list of distractors, this change is not propagated to the other item. This results in the aforementioned effect, and the script (which I didn’t create) attempts to remove those entries by working through all items in the course while “simulating” a change and thus force the system to recreate the distractors.
Since there is no straight-forward way to do this, my assumption would be that you might need to run the script several times.

Now if you actually never inadvertently mixed EN and PT within a single item: I’ve seen this effect across several courses over the years and was always assuming that some edits were causing this. I can, however, imagine that this could also happen if you change the order of the columns in the course or even other settings within the course’s structure.

Please note that I’m a user like you and since there is no documentation about this, all of the above is my personal assumption and could be completely wrong.

FWIW, if none of the above seems to be helping, I suggest you try and post to the thread I linked further up. It’s very likely that @neoncube has a way better understanding about what’s going on than me.

1 Like

Thanks Olaf,

Got it. That’s very informative.
I’ll try and repeat the script a few times and see if that makes a difference, if not, I’ll post it to the other thread.

So, may I conclude that all of these scripts are created by fellow users because Memrise is not too boethered about fixing these bugs?

Yes, as sad as it may sound - it has been like that for years now. Even the most obvious bugs aren’t being fixed. The Android app (which is what I’m using primarily) is full of those. :cry:

Hmm, not good. I guess it’s better then them turning off third-party courses altogether.

Well, you probably yet have to find out that community courses are one of the main (remaining) assets and a true USP of Memrise.

Well, if that’s the case, they’re doing their best to destroy it! lol

Coming back here from → the other thread: I think the probably safest/best approach to remedy the problem would be re-create the course as it’s still quite small (34 words). But I can see that there’s already a substantial count of users who worked on the course, so I personally would want to keep it.

With that in mind, deleting and recreating items is probably not at all what you want as your users will most probably (!) have to again learn those items.

However, the final attempt that I’d work through if I was you would be to go through each item manually and changing it twice (i. e. in database-view, add a letter at the end, go to the next item to save, then go back and remove the letter). With 34 words that should be a matter of a few minutes and thus worth a try.

Apart from that I’m afraid I have no more help to offer. :face_with_diagonal_mouth:

Thanks again for your suggestions. Unfortunately, that didn’t work either.

I think I’m going to create the course again and that will be that. I won’t delete this one for folks already enrolled in it.

I got it!!!

Ok, I didn;t read your comment properly. When you said Database view I imagined you were talking about the normal level view where we add terms. I then noticed the “database” view and everything was an absolute mess. Cleaned that up and Voila!!!

Thanks a million!


So, the way that Memrise does things is… complicated. Unnecessarily complicated, in my opinion XD

Each course has two pieces: The levels and the database. You can see this via the “Levels” and “Database” tabs when editing your course.

When you add a word to a level, it’s also automatically added to the database. However, when you delete a word from a level, it’s not automatically deleted from the database.

When you delete words, ideally you’d delete them from the database. This also deletes the words from all of the levels.

My guess is that you:

  1. Ran into a Memrise bug.
  2. Delete words from your levels but not from the database.
  3. Recreated the words.

This probably means that your database now has two copies of each word: the old, buggy copy, and the new, not buggy copy.

To fix this, you’d need to delete the old entries in the database and then run the Delete Phantom Entries script again.

1 Like

Lol, nvm, looks like you figured it out! XD

I did. :grin:
But I really appreciate the time you took to write that down. It was exactly what the solution was. As you say, kind of a convoluted architecture, but hey, I’ll know for next time. Thanks again

Haha, no problem! :slight_smile:

And thanks to @Olaf.Rabbachin for tagging me ^_^

1 Like

LOL, true in many cases Memrise, obviously / sadly! :slightly_smiling_face: