Solving Ghost Words

Hi all,

As many of you know, we’ve had a long-standing issue of ghost words in community-created courses. When an item was missing a translation or an entire line or level was blank, the system would fail to launch Learn New Words.

To resolve this issue, we’ve done two things:

  1. It is now not possible to create a ‘ghost word’. When adding items to a course, both the ‘test with’ and ‘prompt with’ items must be entered before the creator clicks +.

  2. All previous ghost words have now been removed to allow courses to launch properly, but don’t worry, the removed words will still be stored in your Database tab and can be moved over to a level once they are complete.

Any questions or issues, please let us know :slightly_smiling_face:

2 Likes

So a few thousand image based tests have been removed from my own created course due to this. Is there any quick way of adding these all back into their previous levels or will I need to do this manually? Will I also lose all learning progress for these words?

Wasn’t there a “Save” button before? Why would you replace a clear caption with a plus-symbol? Why even “+”, it should be a save-icon, a “+” is really considered to be used to create a new item and start editing it, no software that I know of ever used it to finish editing a new record.
And why is the button on the left - in the western world, we’re all reading from top to bottom, left to right!

IMHO all of those are fundamental concepts in software ergonomics.

How do you even find ghost words? There’s nothing that would help a course creator/editor to locate possibly faulty items or am I missing something…?

Very good question.

Hi @MemriseSupport , have you found a way to remove old uncorrected alternative words?

This is different to an incompleted line.

This issue has been discussed extensively with laborious methods to eliminate them.

I may look to add the link for you.

Oh dear, that sounds like an unforeseen consequence.

I am looking after several courses that test on images.
But they also have sound and text fields.

I hope I haven’t lost some entries as I’d find it hard to spot an occasional removed item.

Can @MemriseSupport comment please?

Yes, so within my course I have three columns: Question (text), Answer (text) & Image.

On some levels within the course I prompt on Question and test on Answer which is fine and I haven’t lost any of these even though the image column is blank for them.

However, on some other levels I prompt on Image and test on Answer, for these entries I had left the Question column blank because it was not applicable and all of these have now been removed. This is despite the level they were part of being set to the correct ‘Prompt on’ and ‘Test on’, nothing was blank in the relevant columns.

So now I need to into my course database and add something in the Question column for all of these images tests (of which there are 1000s) and then manually add them back into the correct levels.

Hi @Ritz2Rubble,

Don’t panic, I may be able to help you - but I am not sure.

Have a look at this course on the Web and App.

» 15 British Garden Birds - by deactivated user - Memrise «

I don’t appear to have lost anything.

I think I do things differently to you …

MemRise Bird edit

What I do is one entry per item, but then duplicate a level then test on a different pair per level.

So you may be able to reuse and existing level or add to your database the easiest possible way.

Without seeing it, I don’t know if this is your situation.


PS

Incidentally this » course « only has a column for the name and for the image (photo) and it displays fine.



I think I will move this information to a DM or PM later (once you’ve seen it).

I have a Latvian course with 3.000 words and can’t add new words. Is there one of the frequent Memrise problems or some other reason?

same problem and i cannot even add audio o_O

Got the same problem. My course also contains more than 3000 words. Is it a problem of size?

Old topic but I figured why start the same one.

Everything was fine until about 10 days ago when I couldn’t add new words or sentences. Didn’t think much of it, went about my business. Today I tried again, and it’s the same problem. I try to add new material by pressing Enter as well as the little + sign but nothing happens.

The previous posters mention size, that maybe 3000 words (my course is almost there) is a lot, but I doubt that since there are courses with over 5000 words.

Any ideas?

Could it be possible that you stumble over the (call it non-ergonomic) way this works? You need to enter your new word and then click the plus-symbol to actually save the entry.

Check out this thread about ghost words:

I am having the same issue - I can no longer add words directly within a course level. I click the plus symbol and they vanish.

The workaround is to add words to the database for the course and then add them to the level.

Can this be rectified soon? It makes course creation much more time consuming. Thanks!

I’ve typed out both the ‘test with’ and ‘prompt with’, as suggested in that thread, and it’s working. Problem solved.

2 Likes

You’re right, cheers for that.