Screen freezes during reviews


(Woody1) #1

For the last ten days I’ve been unable to finish a review session as the screen always freezes before I complete it and I have to refresh the page. Also, if there are only one or two reviews left the screen is frozen when I refresh the page and I have to wait until more reviews have accumulated before I can continue.

I’ve gone through the “reporting a bug” process but have been waiting for over a week now with no response or fix. Very frustrating.

Is anyone else experiencing similar issues? Or can anyway give me some idea of a timescale as regards memrise resolving this kind of issue.


Courses hanging/freezing
(Overlord Hydroptère) #2

solve this issue? ahem… like never, probably, as the web version is not important for the team, acording to the declaration of their CEO?

i’ve noticed similar in this: Consuming huge amount of resources


(Baite) #3

Let’s ask @memrisesupport. Please, @memrisesupport, could you help out here (see @Woody1) ? Thank you!

When tagged with the @, memrise should get a message of this threat and read it.


(Amythegreat) #4

When you say the screen freezes, do you mean like my problem here? Next button breaks during review sessions Or do you mean your browser becomes unresponsive? Or something else? Did your issue go away or are you still getting it?


(Woody1) #5

Yeah looks similar. I wasn’t able to finish a session for about four weeks. The problem was that only I seemed to be affected so wasn’t a priority for the team. I logged it a few times and eventually someone got in touch and they fixed it.


(Eliras) #6

Same problem here, it’s really frustrating, it’s happening in different courses, from Japanese Vocab and Kanji to Latin. This problem started two or three days ago, before that it never happened to me and I haven’t changed or added any user-scrips or add-ons. Though now that I’m thinking about it, Adobe Flash Player updated itself two or three days ago, that could be the cause.

@memrisesupport @memrisesupport

Edit: I’ve done some testing. First of all I’ve uninstalled Flash Player, that didn’t fix anything, then I disable all my userscripts and that fixed the problem (or so it seems at least), I’ve enabled them one by one and noticed it always freezes when I have the “audio provider” scrip enabled on a course that doesn’t have audio by default. So this seems to be the culprit, though I don’t understand why it would suddenly cause trouble when it worked for months.


(Amythegreat) #7

Is your problem the same as mine (linked in my post above)?

Edit: Responding to Eliras. It doesn’t look like there’s any visible indication on the thread that that’s what I did, so just clarifying.


(Eliras) #8

Yes that was my problem @Amythegreat. The userscript “audio provider” was the culprit for me, the developer was so kind and fix the problem and as of version 0.1.26, I’ve hadn’t had a freeze once. knocks on wood

Here’s the trad in case you’re also using that script: [Userscript] Memrise Audio Provider


(Amythegreat) #9

Thanks for the response @Eliras. I don’t have any userscripts installed though and I’m getting the problem anyway @MemriseSupport @MemriseSupport @MemriseSupport :confused:

On a side note, I think it’s ridiculous that a company that has paying customers seems to have a policy to generally not even acknowledge a problem and let it be known that it’s been seen and is being looked into. If it takes time to fix, fine. I’m not asking for timescales as you can’t know for sure when something will be done until it’s done what with new issues cropping up that take priority etc. It’s just the decent thing to do not to leave people feeling ignored. It’s poor customer service (or a lack of). Why isn’t this supplied? You deal with customers and you turn a profit. It’s like you don’t care if you bother the people who are paying you. I’m now seriously considering cancelling my Pro membership :thinking:


(Eliras) #10

@Amythegreat I guess I jinxed myself by saying it doesn’t happen anymore because I just got another freeze during reviews. :confused: I also agree with the rest of your post, I’ve also bought a Pro Membership and it’s odd that no one seems to be on this issue.

I also don’t know if this has anything to do with the audio provider userscript but I’ll still post in the dev’s thread for it as well.

@MemriseSupport @MemriseSupport @MemriseSupport

Here’s a screenshot with the console enabled, maybe that helps.


(Thomas Heiss) #11

Hi @Eliras

why don’t you open the red TypeError message to see the full stacktrace of the failing functions and user scripts?


(Eliras) #12

Sorry, I missed that. I’ll do that the next time and post the result.


(Jjjhorn) #13

I am having the same issue. Has anyone found a fix? The review freezes. Not the entire site or browser, I can exit but the review will not go to the next word and the timer goes blank.


(Thomas Heiss) #14

Hi,

what course and language is that on?

I did not have problems with 25-50 word reviews either with class or speed review on the web for several offical PT BR 7 or 3-4 user-created courses.
The “50 languages” and PT7 courses are also regularly reviewed by me with “Speed review” since the last code change (slower timer).


(Jjjhorn) #15

I am doing Japanese from Zero Courses 1-3. This has been going on now for about 2 weeks, but I have been using the course for more than a year, previously with no trouble.


(Thomas Heiss) #16

Try to open the browser console with the F12 / Ctrl + Shift + K hotkeys on the Firefox browser.

Look for any red error message or yellow warnings which might be the cause for the Memrise web screen freeze.


(Thomas Heiss) #17

Hi @Eliras

Judging your console red error messages, you are using Tampermonkey userscripts which are not compatible anymore with the more recent web code changes by the Memrise team.

The “MEMRISE.garden.session.timer is undefined” message probably comes from the TimerDisabler userscript.

You need to install a different script version and uncomment some code lines which are not compatible with the API anymore.

Have you followed my latest comment to uncomment old code lines which just bring up red errors in the browser console?

I remember that I had also seen your “TypeError: _.find(…) is undefined” console message but cannot exactly remember which old userscript was the cause.

Have you disabled “Memrise Infinitive learning”, “Memrise Wrong Answer Skips”, “Memrise Learning Retries”, “Memrise Peek Next” Tampermonkey userscripts?

When you collapse the red “_.find(…)” TypeError, you can track down to the JS stack and see what the first or last scripts (including injected ones) might be the source and you can jump into the userscript source.

If you have problems the other way round would be that you list all Tampermonkey userscripts which you are using.
Not too many are fully compatible anymore with the many web code changes by Memrise staff!


(Jjjhorn) #18

I usually use Chrome not Firefox but I tried it on Firefox and it still freezes, in fact on the very first word. Here is what I get:


(Thomas Heiss) #19

@jjjhorn
Would you please click on the arrow symbol before “TypeError” so you see the stracktrace (caller chain) and all the scripts and what was the first and last caller and where the error happens?


(Jjjhorn) #20

Here is what I get