Saying You Need To Review Doesn't Go Away After Reviewing

Here is my Mandarin Chinese 1 course on Memrise, it says there are 9 words to review, but every time I review the words to review count does not decrease past this number. It used to be stuck on 4 words to review permanently, but recently it had increased to 9. It’s a bug I’ve tried to get rid of simply by reviewing a lot, however it hasn’t worked. Perhaps it could be because I’ve chosen to ignore some specific words on the course? Memrise%20photo%2011

I have the same issue, just with a lower number (2). It only happens in one of my two courses.
I have ignored words as well. However, I tried to unignore all words, review everything, but the number of words to review is still kept as 2. It is the same on Web and in the Android app.

If I click the global (blue) review button on the top of the page and all the words are already reviewed (except the stuck 2), then I get an error popup: " Whoops. Could not load the session. Sorry."

Is this something the team is aware of? I can provide more account details to be able to reproduce.

I think thats the point of this forum right? I don’t get an error when I review but it just gives me random words to review instead