Right answer is not accepted

It happened in a course that I just created.
Always on those equations. (when typing strictly was unmarked)
There is no space or anything else.

The cause of this probably has to do with the fact that all those characters would be ignored in non-strict typing mode. From my experience I asume that if in those items there would be a letter or number everthing would be working.

It happened in a course that I just created.
Always on those equations. (when typing strictly was unmarked)
There is no space or anything else.

I think you need to enforce the “typing strictly” for this kind of characters. Did you try?

I did. That’s why I wrote that it only appears when strict typing is unmarked.


Then to me, it is just normal. Only letters can be recognized, I think, if you do not enforce “typing strictly”.

Typing strictly will recognize every character you would choose to use in your course. If you choose to use those characters you need to enforce it.

Did I miss your point?

That’s what I meant, however, I don’t think it should be that way.

There is (probably) nowhere information that, in non-strict typing mode, I’m not supposed to have items that do not contain letters or numbers.

So I think that either such like information should be added, or the behaviour with such items should be changed, because in the end my answer was (perfectly) correct.

Strict typing mode isn’t always good. Yes, it would help me with those 2 items, but it would make rest unnecessarily more difficult.

Sorry to hear of your problems @Rodyzi, I have had probelms in the past and had to avoid “strict” marking.

Just a quick thought, do you haven any hidden characters?

Or are you typing using “alt” keys instead of the symbol or areyou selecting them from a digital list that MemRise an provide.

I don’t have any hidden characters. I typed everything straight from keyboard.

If you want you can experience it yourself just by creating a quick test course where answers consist only of non-letter and non-number characters such like !@#$%^&±.

If you can give me a link to the course, I’ll try it for you.

right answers (in _alts) sometimes not accepted in my own course http://www.memrise.com/course/813123/2-a-cidade-de-lisboa/

(in this case “agua de torneira, agua encanada”, without the accents)

Hi @Hydroptere,

I had terrible trouble a few years ago. I set up “strict marking” to avoid a problem and put hidden alternatives (ie with “_”) and I think that became part of the expected answer! Which just made things worse.

The original problem (which I think was to do with leading numbers) is still outstanding.

Here is a recent reminder to the MemRise team, for completeness:

hi, @DW7: strict marking is not enabled, i never do that in my courses … however, i know about this problem, that is why i always add in _alts also the alternatives without any accents (i’d like to find that keyboard for Poruguese characters, but… there is nowhere to find). I think the database is again in scrambles and gives tardy reactions

Oh, okay @Hydroptere,

One point of interest, I have been a contributor on a lot of Italian courses and have of course completed them. (No pun intended.)

I found that just typing the letter (character) without the accent (eg just “e”) in a word was also accepted. I don’t think any alternatives were set up.

I take it you have tried that? If you have, I’ll go back and investigate further.

1 Like

DW7: wow, many thanks for your “Hilfsbereitschaft”… helpfulness?

But let it be for a while, I do think the database needs again some time to update - those items were the ones that got audio just before, I therefore suspect it has something to do with changing the entry…

And: if an alternative, which is not the first in the front line (in the definition) or it is not in the front line but simply a visible alternative, has accents, the user has to answer with accents. Unless the creator adds all possible alternatives :sweat:. If one has as definition a row of synonyms, if (only) one of these contains an accent - than the whole row is somehow automatically set on “strict typing”. Unless the creator adds all possible alternatives in the _alts (which I almost always do :sweat:)

1 Like

Perhaps I have been fortunate in getting away without using accents!

Hi @Rodyzi, doesn’t your excellent post here help? Cc @Hydroptere

From what I can gather I suppose it doesn’t since Hydroptere wrote that she didn’t put course in stict typing mode, which would require user to type in answers with accents.


Do you mean this keyboard?


yes, Rodyzi, I meant that one, and yes, I never set my courses on strict typing (never ever)

many thanks

A post was merged into an existing topic: Correct Database but still wrong answer

A post was merged into an existing topic: [Course Forum] 1-7 اللغة الإنجليزية لمتحدثي اللغة العربية by Memrise