Reviews/listening skills don’t load

Starting from today afternoon, I found that all the reviews/listening skills practice not loading at all, whether it is a Memrise official course or a community-created one, in either Russian or French. The other features function well, but every time I click on the practice button of review/listening the APP has a flashback and clashes. I’ve tried reboot my device (IOS) but it still doesn’t work. I hope this bug can be resolved soon.

I’ll tag @MemriseSupport for you so they get notified about the problem.

1 Like

Hi @soul_of_espresso, sorry to hear that!

Can you please try uninstalling the app, restarting your device, and then reinstalling it?

If the issue persists, please confirm the following:

  • Which device and OS you’re using
  • The version of the app (you can find this in settings)
  • If you have a video of the issue, please send it over

We look forward to your response.

Best wishes,
Memrise team.


Thank you very much!

Thank you for your response. I did the exact uninstall-restart-reinstall procedure and it still doesn’t work. My device is iPhone XR, iOS 13.3.1. Oddly on the Memrise page in my settings there is no version information, but since I reinstalled the APP just yesterday I assume it’s the latest version.

I have recorded a video, but it seems I cannot upload it directly here. Should I send it over by email?

Hi @soul_of_espresso, yes please. You can attach your video in a message to our team here:

Looking forward to hearing from you,
Memrise team