Review not working


(L0rri) #1

I’m trying to review all my words in the Italian category, starting from the dashboard. All reviews were working fine all day, but now I’m getting an error: “Whoops. Could not load the session. Sorry.” I’ve tried several times but it keeps coming up. Thanks for fixing!


(Thomas Heiss) #2

In Firefox press the F12 hotkey to bring up the browser console.

Please check for red error JS messages.

Because you already get the “Whoops…” popup message this may or may not give you additional informations what went wrong.


(L0rri) #3

I don’t see anything in red, just pink. Can’t fix it on this end anyway :slight_smile: It was working okay again until just a couple of minutes ago. Then it allowed me only two words to review, and then went back to the same error message.


(L0rri) #4

Just a follow-up. I can now review Italian words, but whenever I get down to that same batch of 108 words that are left to review, it once again displays the error message. Is there some way Memrise can zero it out?


(Thomas Heiss) #5

First the issue exactly needs to be replicated.
This is hard to do without any specific error messages or stacktrace from the client side.

I have no idea if a detail error message / stacktrace is printed on Memrise’s server log.

Because of this, if you see ANY error messages (incl. pink, ehm, what does that stand for?) in your browser console, you might want to copy the detail stacktrace from all the scripts into here.
Or at least add this detail information when you file a bug report.


(L0rri) #7
  1. https://en.wikipedia.org/wiki/Pink
  2. After looking it up, I still have no idea what a stacktrace is. I am not a designer, developer, programmer, and have no desire to be. No need to get snotty with end users (your little “ehm” comment).
  3. I am uploading a screenshot. After that, I’m not wasting any more time on this. If Memrise wants to fix their problem, go for it.


(Thomas Heiss) #8

Nah, that wasn’t it.
I was just so astonished as I never heard something like that and I had no clue how to interprete it.
Please do not feel offended, I always struggle for words in English as it is not my native language.

Good news: You are almost there.

See the 1st tab “(Html) Inspector”?
You clicked on it and the text is basically all the html code with CSS on the right side.

Do you see the 2nd “Console” tab?
This is the developer console where all errors should be logged, if there might be shown any, if you are lucky.
There is an arrow “>” on a red error message so you can unfold the detail stack below the error message headline.


Q: Do you maybe use any Tampermonkey user scripts which might stop the review?

Today I successfully passed 100+ words for a user created PT BR course and I have not seen your mentioned Memrise popup dialog.

Is this now course specific or even only related to your user account???

I wish I could better help you.


(L0rri) #9

Sorry, my apologies. If I had known that, I wouldn’t have responded that way.
I tried the console tab but there is nothing there. It’s just blank.
No Tampermonkey scripts.
I can review many words but it just gets down those last 108 at the end and that’s where the error occurs. It could be course-specific but I have a couple of dozen Italian courses so I don’t know how to figure that out. I’ve gone to a couple of them where I thought there should be some words for upcoming review, but the review bar isn’t highlighted. Anyway, thanks for trying… Memrise had similar problems a few years ago when they did an upgrade, so maybe they’ll figure this one out if other people start having the same problem. I’ll just live with it for now :slight_smile: