"Record" button does nothing at all on Decks, but now works on Memrise

Fun stuff! So now, in Decks, the ‘Record’ button doesn’t work when I want to record my audio. Nothing happens at all, no error, no nothing. Tried in both Chrome and Firefox. However, I went over to Memrise to see if course creation had been re-enabled over there, and it had; recording there still only works in Firefox, however, not Chrome or IE.

Perhaps the button is disabled in Decks because someone is working really hard on a new and improved recording tool that works properly for all browsers and they don’t want it being mucked about with while they’re working on it? crosses fingers


Are you sure about that? From my recent experience, you can add audio files and edit existing community courses on the memrise web version, but you can’t create new courses; that is only possible on the Decks website.

There have been posts appearing here on a daily basis complaining that course creation isn’t possible on the memrise website, so I would be very surprised if this had changed as it would not make sense to re-introduce it when community courses are being moved to the Decks website (and, in future, also a Decks app).

Apologies, I misspoke. I hadn’t tried to do any course editing on Memrise since Decks came out, so didn’t realise that it was a half and half situation, I’d thought editing was completely disabled over there (I clearly hadn’t read those posts very carefully). It was enabled enough that I could do what I wanted, is all I meant.

Does the record button only work in Firefox? It doesn’t work for me in chrome.

It hasn’t ever worked for me in Chrome, so I’m using Firefox for recordings. I should add that it only works on the desktop version (Windows here), but on neither of my Android devices.

Is the record audio button working for anyone, anywhere right now? I tried on both Chrome and Firefox, and it has no effect on either. No indication the button was clicked, no error, no pop up, no change in color, no bells, whistles, or anything. If anyone knows a trick or a different browser to get it to work, that would be awesome.

For me it’s exactly as it was. No effect whatsoever on the Decks site, but on the original Memrise site it is still working in Firefox. Don’t know for how long that will be the case of course. :frowning:

I can also confirm that the Record button does nothing on Decks while it works on Memrise.
@MemriseMatty, @MemriseSupport: would you kindly see into this?

Edit: it seems that the Event listener is missing on Decks:


Thanks - We are aware of this issue. I’ve asked the Decks team to investigate further. Hope to have a resolution shortly.


I see an error now in chrome and ff for the swfobject.js not being loaded that I think relates to the record button not working. This is from Decks.