Problem navigating to my "Home" page of courses (on the Android App)

I don’t use the App much (as I prefer the web for more features and information) but have dipped into it.

I have just been to the new app and I felt sure that touching the Home button (bottom left) took me to all my courses.
Touching it now has no effect! Even touching it after touching “You” just takes me back to the current course.

I eventually found I had to tap the luggage icon in the grey circle on the top left to get to all my current courses, in order to change course.

Is this correct?

Cc @anon13174193

Tap the flag icon on the top left. This will open up your course list. Alternatively, swipe from the left edge to the right.

That’s what I thought was the luggage icon in the grey circle on the top left.

Thanks for the brilliant alternative (swipe left to right) but I still think the Home button should take one home (as it does on the web).

See this below:

Mystery solved - you said flag and I said I have a grey luggage label in a pale grey circle - because that’s the icon for unclassified courses!

1 Like

I might be mistaken, but from what I recall the home button takes you to the home screen of the current course. There is no such thing as a home screen in the app - there will always be a course unless you go into settings, etc…

1 Like

Hi Olaf,

Do you ever experience any problems doing this? I first reported it at post No 89 here and, although tapping the course icon or swiping L to R from it sometimes brings up the course list as you say, more often than not it doesn’t. It just moves you back and forward in the same course. I find I usually have to try several times over several minutes after opening the app before my course list will display.

I don’t think it’s as intuitive as it should be and would appreciate it if @anon13174193 could take a look at improving course navigation.

1 Like

I often get the same problem.

1 Like

Actually I hardly ever swipe - I simply click the flag icon. I just happened to find out about the swipe movement a few days ago. (Well, I’ve only been using Memrise for 1.5 years! :rofl:)

1 Like

Thanks! That’s interesting. Maybe it’s a device-specific thing. I came across the ‘tap on the course icon’ thing purely by chance. A subsequent search of the FAQs found a reference to a menu icon which is not present on my device but I recall seeing it mentioned in a post by someone else recently.


It’s just a bit more ‘clunky’ than it should be but, if I wait long enough and try often enough, I eventually get to see my course list. :persevere::slightly_smiling_face:

1 Like

Oh sorry, my bad, I absolutely misread. Lack of brain today.
I thought you were talking about when you click the flag, I somehow missed the swipe thing.
I have no clue about swiping, I get the problem when clicking on the flag.
The menu icon was there before, but it was removed with he graphic changes.


It’s ok. I was talking about both. I get the problem with both tapping and swiping…most of the time.


Not only that - I just checked. On my tablet I’m still running the old Memrise app and it looks exactly like in your screenshot. On my phone though I see the new design. And it seems that they combined the menu button and the flag into a single button. IOW, with the new design, the menu button is gone. And this is where you now have to click the flag instead. Sorry for being so imprecise - you simply miss details for things you use rather automatically / without thinking.

Here’s my tablet:

And here’s the phone:


Mystery solved - you said flag and I said I have a grey luggage label in a pale grey circle - because that’s the icon for unclassified courses!

Actually I think this is one of at least two new bugs (sigh) in the latest app version. I just updated my tablet and reviewed a few courses. Regarding the menu button I saw that it is not only missing in the main screen but also in the leaderboard lists. My assumption is that they simply forgot to provide an icon/GIF for the menu button. Since the button is graphics only, it’ll simply be invisible or at least next to invisible (depending on borders, margins etc.)). Conclusion: it’s a bug, not a feature.

I’ve filed two new bugs in #17 and #18 here:

I so much long for an app update that actually FIXES a problem rather than introducing NEW ones! :weary:


This from @Joshua in > Android bugs < Regarding #17

CLARIFICATION - Flag for languages, but other icon for other categories while Community courses are on the MemRise App.

Apologies for the late response. I presume the issue happens when you tap accidentally not on the courses list icon (we use flag for the official Memrise courses and for the community created ones it can be a different icon) but on the Course title. I agree that it’s a very easy mistake to make and I’ll report the problem to be fixed.
I also would like to clarify that the hamburger icon was removed deliberately and we left only the flag icon (both were triggering the course list).


Hi Masha,

Thanks for replying. I think you may have hit on the problem.

I have just tried it again and it’s behaving as it should do when I am careful to tap precisely on the course icon. For those of us with fingers the size of sausages (:grinning:) the ‘target area’ is quite small and currently sits very close to the course title, so it’s quite easy to stray into that part of the screen. So, maybe putting a bit of space between the two, if possible, may offer a solution.


Many thanks for your reply @Masha_Ignatova48, what I personally think is the “Home” button on the App (at the bottom left of the screen) should take me to all the courses I’m currently studying, after all that is what happens if you click “Home(top right) on the web (from a course).

Currently, although a house and home is there on the App, tapping it has no effect!

So I was after conformity.


For instance if I were studying MemRise Italian and MemRise French, I would NOT expect tapping the Italian flag would take me to all courses including the French.

Oh I see now! We’re considering changing the flag icon regardless for several reasons and we’ll take your feedback into account when choosing appropriate icon.
Home icon in the bottom left corner takes you to the overview of your current course indeed and we’d probably keep it this way as majority of our customers are learning only one language at a time.


Thanks for looking into this @Masha_Ignatova48 - but the point I make is that the “Home” word on the MemRise web, even within a course (ie a level) takes me to my ‘home’ ie all courses and not the single course, so that is why it confused me.

Home icon in the bottom left corner takes you to the overview of your current course.

The home icon on the app, at the start of a course (which hos all the levels), has NO effect at all. (Try it on an android.)

There is NOT a home button within a level.

I now know what to do thanks to people above BUT it’s not obvious and I naturally went for the Home button having been used to the web.

Can anyone else confirm this, please?

Thanks for reiterating your point, I agree that it isn’t ideal that the Home section contains different information across different platforms and it’d be right to make it consistent in the future.