Portuguese (Portugal) 8+?

Does anybody know: is Memrise planning to come out with a “Portuguese (Portugal) 8” class?

I’ve done 1-7, and what’s listed as 8 is apparently by someone else, and not up to Memrise’s usual level of quality.

the Ultimate Portuguese course is very useful to increase learning. (I’m not just saying that because I made it) another really good one in my opinion is this

1 Like

I’ve just started the Ultimate one. Seems good so far, much better than the #8. :slight_smile:

The audio doesn’t work in later levels, I tried to figure out why but nothing worked. Let me know if you find any even tiny errors.


Okay. I’ve run into what might be a bug but it seems to be the same in the official courses so I dunno, but anyway: often (but not always!), when the word it WOULD speak is the same as the immediately preceding one, it doesn’t. Kinda like maybe the code says “if it’s a new word, load it and speak it”, when it should be “if it’s a new word, load it. then, speak whatever’s loaded.” If I were looking at the actual code, there are some pretty common bug-patterns I’d be looking for, especially the same one as caused Apple’s “goto fail” bug. (I’ll spare everybody the geeky details; if it would help, I could DM you, but I have no clue if that’s even relevant to how these courses are made.)

sorry I don’t really understand what you mean.

I mean like if there are two exercises in a row where it would speak some particular word to me, sometimes it doesn’t on the second one. I have not noticed a pattern to what kind of exercise either one is, but let’s suppose the first one is a multiple-choice “translate this word from English to Portuguese”, prompting me with “ten”. So of course I pick “dez”, not one of the other three options it presents me, and it speaks “dez” before it goes on to the next exercise. Now suppose that next exercise is a “pick the English for what you hear” one, and it’s supposed to say “dez”, prompting me to pick “ten” (from among three other options), but it doesn’t say “dez”, or anything at all.

oh I get what you mean, sorry for not answering I missed this. I think that’s just a bug on MEMRISE itself, because that same thing happens to me all the time no matter what course I’m doing.