Pictures don't appear

Both in my cellphone (MLS with Android 5.1) and my tablet (LG with Android 5.0.2) pictures of a course I made for my son, don’t appear:
http://www.memrise.com/course/730299/-12873/

Instead, I get to see the path to the jpg. Please, check the attached screenshot.

I suppose that is not the expected behavour, right?

:slight_smile:

1 Like

In app version pictures will appear if they are (a) tested (b) promted with. No pics will apear if they are set to always show but not (a) or (b). As long as I have used app (over a year).

Indeed, I have “always show” set.

What do you mean by tested and prompted with. (Sorry)

:slight_smile:

To get this


You need to study on words and prompt with pics

I see. But I want words to be prompt with Greek and pictures just to appear in order to introduce the word and give some visualization to the learning process. Matter of fact excaclty as the course tries to do (by showing the file path) but for some reason cannot deliver.
:confused:

1 Like

You can insert pictures in mems. (I’ll make you a screenshot later)

But I don’t want them in the mems. :confused:
Matter of fact I don’t want to change anything. On the PC it works perfectly! The only problem is that on android instead of showing the photo it shows the photo path which seems to be a bug.

1 Like

Then you have tu use it on PC. There is no room for a picture in phone app

Apparently not. Still the path appers when it shouldn’t. I consider this to be a bug. It needs fixing or else a different approach that could show the picture somehow. I’m sure there are ways.

the path appears because there is some room for words that are always shown. I use it in my own courses. It can’t show a pic, but it can show the address, because it is in words

and therefore it’s a bug.

anywayz… i hope they’ll get to it sometime…

I’ve exactly the same issue. what the difference between image and mems ? I’ve uppload photo for each worl of the level but it don’t consider it as mems ? So where I can upload mems on the lesson editor panel ?

You’ll need to add the pictures as mem’s instead of creating a 3rd column for image in the database. The Image url is shown because pictures can’t be shown when not tested.

Here’s an article regarding what mem’s are and how to create them:
Website: http://feedback.memrise.com/knowledgebase/articles/524873-what-is-a-mem
Android: http://feedback.memrise.com/knowledgebase/articles/729816-how-to-create-a-mem-android

8 Likes

I just finished creating my course, and I noticed the bug with the pictures in the app… I don’t want to learn on computer, also I don’t want to put each picture in mems, it takes too long time and it is not the behavior I want. I am very disappointed this bug still exists after at least 3 years.

1 Like

i’m writing from Earth, 14.10.2019 the problem is still the same. We can’t see the images on the android app. Are you reading here??? heeyoo it is a serious bug.

1 Like

I recently went from an iPhone to an Android and now I am experiencing this issue. The images show up fine on the web and on iOS devices however on android it just shows up as text. This is a serious bug because Android users are missing out on visual information that creators have implemented into their courses. I have already added all my images to the databases and do not want to go through the process of adding them to the mem section, moreover, I am using the mem section for other images that are different to the image column. I am surprised it has been over 11 months and this bug is still present.

1 Like

Hi @SKKreativ,

That’s odd. I don’t get that problem for the image-based courses I have on my Android app. The images load OK for all the courses (some I created and some created by other users). I’m wondering if there is something in the course settings that is causing your problem (see Atikker’s posts above). Could you post a link to one of your courses so that I can try it?

2 Likes

Hi @SKKreativ,

Sorry to hear you’re facing this issue! Would you be able to give us a few more details, so that we can investigate the problem?

It would be great if you could let us know:

  • Which course(s), levels, items or sections in the app this occurs with
  • Which device you are using
  • Which OS you are running
  • Which version of Memrise you are using (you can find this information at the bottom of your Settings in the app)
  • Do you have any screenshots of the issue?

Looking forward to hearing from you,
Memrise team

3 Likes

Hi there, thank you for the response.

I have noticed it is happening across all of my created courses.

On my iphone 6 plus I didn’t have any issues with the images displaying. On my Android (Blade A3 2019-T) I am experiencing this and the version I am running is 2.94_23003_memrise.

Here is one of my course I am experiencing the issue with: https://app.memrise.com/course/5786459/german-pokemon-names/

This is how it looks on the web, with no issues.

This is the settings in the database, with “always show” clicked. I have also tried this with the “show after test” option.

Here are some of the screenshots from my android, with no images displaying even when I have changed the database options…nothing seems to work.

Kind regards, Stefan.

I also would like to add I do not want to change the prompt with English to prompt with images because I want to be tested on the words and not the images. I just want the uploaded images to display alongside the words in the levels.