Offline courses will not download----again

So, last year some changes were made and as a premium user for about three months I was unable to download courses for offline use. I fly WEEKLY and usually like to practice on the plane using the Remembering the Kanji course. After three months, a new app version came out and I somehow got it to download successfully after many attempts and all the usual tricks.

A few weeks ago I allowed my Memrise subscription to lapse as I cancelled it when I was originally having the issues with downloading. I quickly bought another subscription and attempted to re-download my courses to discover the issue is STILL happening!

I tried three different courses on two devices, a Samsung Galaxy S7 and a Google Pixelbook. Neither works. It says “Course Downloading” and then after about 30 seconds says “Download Complete” but if you exit the course (To the main menu) and re-enter it goes back to “Download Course”. Obviously if you are offline it doesn’t work.

It’s CRAZY that premium users basically get ONE useful feature—the ability to use the app offline and IT DOESN’T EVEN WORK. Now I’ve paid for a full year and unless this gets fixed I’m just throwing my money in the trash on an app with features that haven’t worked correctly after YEARS of problems. Literally YEARS.

If I can’t get this to work sooner rather than later I’m absolutely done with premium. If it’s a month or two of fiddling with it and clearing the cache and restarting to get it to just barely download I’m not throwing my money away on this next year.

I’m as frustrated as you about all this, there’s countless issues that nobody seems to ever tend to.

@MemriseSupport: I can’t tell you just how frustrating this is, particularly that even getting a reaction from you guys (see i. e. my Android bugs thread) can take anywhere between a few days and even years (no kidding!).

Good morning @maxride and @Olaf.Rabbachin,

Thanks for reaching out. We’re really sorry you’ve experienced this problem again :disappointed:

Our developers have identified and fixed this issue, which will be included in the next Android release, so please keep an eye out in the app store.

Thanks so much for your patience.

Kind regards,
Memrise team


the only reason i signed up and paid was to have download capability. when is this fix coming???

oof I thought download courses is only for paid users. But I just discovered now it’s a bug for everyone!

Hi all,

This bug was fixed with Android version 2.94_24409 of the app. Can you please confirm if it is still not working after updating to this version from the app store?

Kind regards,
Memrise team


Thank you for working with us to actually get this issue fixed.

Unfortunately the issue still persists. I verified the version number, cleared data and cache, then force quit the app and logged in again with no luck on two courses.

Click download and get “Gathering information” and then after about 20 seconds it goes straight to course complete but doesn’t actually download anything.

Scratch that, after uninstall and reinstall I was able to get three courses to download, so something is working…better.

The main course I use, Remembering the Kanji, still won’t download…but the feature is working much better now.

Hi @maxride,

Thanks for letting us know this. I’ve reported back to the developers working on this bug to look into this again.

Thank you for your patience,
Memrise team

1 Like