New layout - problems with hearing the audio files

With the new layout introduced the audio files for the words are not audible correctly. The sound is played, but it is automatically cut after a few seconds, so you can’t listen until the end of the file. This happens even with some short words, but gets even worse when the whole sentence is in the audio file. Please bring back the possibility to listen to the full audio file.

Hello @Winard and welcome to the forum! :slight_smile:

I only tested this with a course without audio so I can’t confirm, but I’d suggest you edit your post and add information about the browser that you experienced this with.

As with the Enter-key (see → this posting and the ones afterwards), I reckon that this will probably be a browser-related problem as well.

1 Like

Hi Olaf, thank you for quick response. I originally used Firefox, but now tested in out on Microsoft Edge and the same thing happens.

Can you be more specific on which course this is and ideally which phrase and which level it’s in please? That way we can test it directly to understand the issue.

1 Like

I just tested this with a music course on Firefox and encountered no problems with the sound.

1 Like

Hi All, I face this issue on all the courses I take and all the phrases, this is not limited to any specific phrase or level.
For example: this course for single words

or this course for full sentences

I have a similar audio related problem. After being forced to use the new web version the audio rarely plays after giving the correct answer.

I am used to use the web version with Chrome on my iPad because the iOS App has no typing only feature.

I have the problem with all of my thai courses. For example Thai frequency, top 4000 words, Thai essential grammar, Pocket Thai. It’s a real pain to learn a tonal language and aren’t able to hear the audio after giving the correct answer.


I’ve tested this on my device on the courses you mentioned and could not reproduce it. All audio files are playing correctly on every mode I try.

To troubleshoot this, first of all, please try the following steps:

  • Please make sure AdBlock, AdBlocking technology or Ghostery have been disabled
  • Clear cache and cookies
  • Disable any active userscripts
  • Ensure your browser is updated, and restart it
  • Can you try loading the session in Google Chrome?
  • If Chrome fails, can you try loading the session in incognito mode?

If the issue persists, can you please also try the following?

On Google Chrome:

  1. Go to the Chrome menu ( ⋮ icon) at the top-right of your browser window, then select More Tools > Developer Tools.
  2. In the Chrome developer tools make sure the “Console” tab is clicked
  3. Try launching the feature that’s not working for you as usual until you get the error
  4. Take a screenshot of your whole browser window, making sure to catch the error message(s) and send it to us

Finally, to help us investigate further, on any new report please also make sure you add the following details:

  • Which device you’re using (make and model)
  • The browser you’re using
  • A direct URL to the course(s) this occurs with

Thanks for your collaboration!

Hi, I downloaded and installed Google Chrome and followed all the steps. Nothing helped including incognico mode. Please see below a screen shot from the Devoloper Tool, but when playing the audio no new mistake in red appeared, so I believe this is not covered in this tool.
However what I observed about the error that it appears only if I use the option “Classical Review” and when I need to do words that are scheduled for revision. If I went into a course and just clicked “Review” the audio was played in full. The audio is also played in full when I learn new words (but only in the first screen) and when I make a mistake and the tool is displaying the correct version of the word.

Part of the issue is if you answer correctly and then press enter to go to the next word (classic review) the audio stops. Can we not have the audio keep playing? Currently I hear the first syllable of every word I get right. But I don’t want to just wait until the audio finishes before looking at the next word.


Bug/Problem: Audio rarely plays after a correct answer
Make Model: Apple iPad 6. Generation
Browser: Safari
Course: Words from Manee and Friends - by amyhere - Memrise
Last Test: January 20th - Review: Only 1 out of 20 items played the audio after giving the correct answer.
Remark: It’s strange that it sometimes works. I cannot recognize a pattern yet.

Course Thai frequency, top 4000 words - by BlueRock68 - Memrise and Thai frequency, top 4000 words - by BlueRock68 - Memrise have the same problem.

In my case I don’t press enter. The audio stops, because the tools automatically progresses to the next word.

I have the same problem using Firefox or Chrome on my laptop. Disabled AdBlock, cleared cache and cookies.

I don’t know what “disable userscripts” is.

Memrise, however, works fine on my mobile phone, in which case we can deduce that the course isn’t the problem.

It works fine on my mobil phone too. But I don’t like the mobil app as it doesn’t cover the features I like, so I rarely use it.
I tested it today on some other computer (Chrome & Edge) and the error didn’t occur. However I don’t know what is wrong on my computer. I cleared & restarted everything I could. I even downloaded Google Chrome as I didn’t have it before (I mostly use Firefox) and it seems that on Chrome the audio is played longer and the error occurs less frequently, but definitely it is still there. Especially at the last word of the review. In the middle of the audio it just skips to the summary page.

Thanks for the extra details, this has now been raised to our team: internal code WEBSITE-3283.

If you have further details on this, please do share them here - it would be especially useful to know more about the following:

  • Which other courses and items this occurs on
  • Whether you see any errors in the console (see details on how to check in my previous message)

Thanks for your patience.

Bug/Problem: Audio rarely plays after a correct answer
Make Model: iPad 6. Generation, iPad mini 5. Gen., iPhone XR
Browser: Safari, Firefox, Opera, Edge
Last Test: June 19th

Remark: Basically I have the same problem since the rollout of the new layout.
But I had no audio problem on my Trekstor Primebook C11 with Windows. Yesterday I tried Memrise on my new MacBook Air and had the same audio problem. I could solve it by changing the autoplay option for in the safari settings. Unfortunately iOS 15 doesn’t have a similar option / feature. At least I wasn’t able to find it.

I would really love to use the website version of memrise on one of my iPads because I can use different keyboards on those devices.

Hi @Astaroph, I also cannot see an option for audio, but are you able to try these steps:
Go to Settings > Accessibility> Per App Settings > Safari > Scroll down to Auto-Play Video previews (toggle on)

thank you very much for your reply. Unfortunately it didn’t work on my iPad and iPhone. Additionally I tried it on my iPad with Edge, Chrome and Opera. There was no toggle option, but I could choose between Standard, Yes and No. Of course, I chose ‘Yes’ at first, but I even tried all of the three options and it didn’t make a difference.

For me it’s kind of strange because it sometimes works and plays the audio. It’s like there is a random number generator working in the background. I cannot recognise any pattern yet.

I also played with the experimental settings of safari and I couldn’t find a solution.

Thanks for letting us know. Does this happen on particular courses/items or always?

It always happens during a Classic Review and it isn’t item specific. Sometimes the same item plays the audio and more often it doesn’t.
There is no difference between official and community courses. Both experience the same audio related issue.