Memrise submits answers while i still type them

  • Description of the issue: *Normally, when you type in an answer with the Japanese IME, you need to submit the autocomplete given by the Japanese IME with enter. if you do press enter, it takes what you have pressed in and you can write further. this always worked fine here on memrise, but since today suddenly it SUBMITS the answer. this shouldn’t happen normally, since now it is submitting my answer WHILE I STILL TYPE.


if i type "猫” , i write “neko” on my keyboard, then hit spacebar to select the kanji and hit enter so it accepts the selected kanji for cat as the word i type. then i can write the rest of the sentence. but if i now hit enter to select this kanji, memrise suddenly thinks i want to submit the answer and submits only “cat” as the answer and won’t let me write the rest of the answer.

short: i can’t do anything anymore on memrise now since it is always submitting only half of my answers and won’t let me complete any sentence or word before submitting… resulting in only wrong answers.

this started today without me changing or doing anything, and it is really frustrating since i now can’t learn anymore.*

  • Your device and browser details Windows, Firefox

EDIT: i now have recorded a video where i show the bug. the first example is the bug, the second part of the video how it should be.

to make sure nothing is wrong on my own device, i checked if this still works on other websites and applications like duolingo… and it does. so it is a issue with memrise, not my device or settings.

did you do any changes today that could lead to this issue?

1 Like

Went to forums specifically because of that issue
It wasn’t present to me yesterday (nor anything was done with cache)
It makes impossible to fill several answers at all when studying japanese

1 Like

Hi, sorry to hear you’re experiencing this!

I’ve created a ticket for this and our team will look into the issue asap (QA-1322). If you have any further details, please let us know here.

For the time being please consider using the on-screen keyboard instead.

Apologies for the inconvenience.


i have currently switched to the app & clicking with the mouse instead of typing… but it is still frustrating to type like that since it takes 3x the time it usually would.

1 Like

This should now be resolved, apologies for the inconvenience.


hey :slightly_smiling_face:!
i just tested it and it works now again - thanks a lot for the quick response!

Kusuri :slight_smile: