Memrise Release Notes - 28 Nov 2017 (Update on changes to typing test)

you can use the extension adblock to block it. for me just right clicking adblock and clicking block an ad on this page, then selecting the in app keyboard worked

1 Like

Just to keep things together, you can use the following two scripts to revert the changes made to learning in this update:
for the auto accept, use this:

link: https://github.com/stream009/greasemonkey_scripts/raw/master/MemriseDisableAutoAccept.user.js
Short explanation:
Install tampermonkey (extention) for Chrome or Firefox, follow the link and click install.

On firefox tampermonkey can be installed by going to this link:
https://addons.mozilla.org/nl/firefox/addon/tampermonkey/
and clicking on Add to firefox.

On chrome go to this link: https://chrome.google.com/webstore/detail/tampermonkey/dhdgffkkebhmkfjojejmpbldmpobfkfo?utm_source=chrome-ntp-icon
than click on Add to chrome

.

For removing the keyboard below the answer:

To use this first download adblock.
On firefox follow this link: https://addons.mozilla.org/nl/firefox/addon/adblock-plus/
Click on add to firefox.
After installing the extension (and possibly restarting your browser), click on the ABP-sign somewhere around the top of you browser.* Click on the sign and click on options (at the bottem). Then click on the advanced tab on the left. Scroll down and click on ‘Edit filters’. Than paste the following line in the textfield above:
www.memrise.com##.clearfix.keyboard
Reloading your memrise session should now be enough to remove the keyboard.
*If for some reason you can’t find the sign. First restart your broswer. Then click on the three horizontal bars on the topright of your screen. Click on customize, next to the paint brush. Click and drag the ABP-sign to somewhere on your URL bar. Press Ctrl+W and continue.

On Chrome follow this link: https://chrome.google.com/webstore/detail/adblock-plus/cfhdojbkjhnklbpkdaibdccddilifddb?utm_source=chrome-ntp-icon
Click on add to Chrome.
After installing the extension (and possibly restarting your browser), click on the ABP-sign somewhere around the top of you browser.* Click on the sign and click on options (at the bottem). Then click on the tab ‘Add your own filters’.
Paste the following line to the left of ‘Add filter’: www.memrise.com##.clearfix.keyboard
Click on '+ Add filter’
Reloading your memrise session should now be enough to remove the keyboard.
*If for some reason you can’t find the sign, first restart your browser. If it’s still not showing up, click on the orange exclamation mark at the top right of your browser. Then click on ‘adblock is disabled’ and on ‘Give permission’. After that, continue with the rest of the explanation.

Big thanks to Stream_nine90 and lprg for making these scripts <3

Also, it’s pretty sad that memrise has to rely on its users to revert changes that people obviously didn’t like that much instead of providing an option to simply disable them.

8 Likes

Many thanks for the userscript and the instructions!

1 Like

So, the previous suggestion to use the “Ublock” extension does get rid of the unwanted screen keyboard. Here’s how you can sort of turn off the useless “auto-enter” when you finish typing a word. Add a punctuation mark at the end of each word, such as a period. Memrise will not auto press the Enter key for you after the last letter because punctuation is optional.

Please note:

Greasemonkey 4.1 newest update from 12/12/2017 won’t work anymore with any installed user scripts (e.g all typing, auto correct, timer disabler, etc.).
The addon auto-update crashed both my systems and I lost my streak on one Memrise course before midnight.
As soon as you start Firefox, you can’t do anything about the addon “auto-update”.
You would have to disable it in the config / XML files before manually, before starting Firefox!!!

I run Firefox ESR 52.5.2.

You manually need to downgrade to Greasemonkey V3.17 and disable auto-updates.

All user scripts would need to be rewritten for Greasemonkey V4.1 / Firefox V57.0, as mentioned on their website.

Users who are using Chrome (or Firefox) would have to migrate to Tampermonkey (I never have tested Tampermonkey on Firefox <57.0 or newest Firefox V57.0 and did not know it is also available for Firefox).

Memrise: please make it possible to disable auto-complete!

8 Likes

Thank you for the clear explanation. And thanks so much to @stream_nine90 for writing the script.

1 Like

is there any solution to remove the keyboard with a script (that turns one can turn off/on)? for the courses asking for strict typing… i cannot turn down ublock every time i need the special characters that the course creator provided (btw, to recap, in user provided courses, if the creator added the special characters for the respective language, then one does not get bothered with memrise’s “anagrams”)

the silence of the team is deafening

1 Like

Thank you so much for writing this.

(Posted this in the wrong memrise announcement, so repeating here.)

It seems there is a way for course creators to override the awful anagram/jumbled letters issue that is plaguing non-language courses (and language courses without special alphabets).

Under ‘edit course’, ‘edit column’, ‘testing’, ‘keyboard characters’, entering any characters will override the anagram-of-the-answer feature. For instance ‘a’, ‘thewholealphabet’ or just a full stop. Users can still of course type what they want and are not restricted to what is entered in this box.

I have now done this for my created courses - I hope the course creators do this for the ones I’m a consumer of.

A further workaround I have used for the other problem of auto-acceptance is to change my target words to begin with capital letters. Since most people won’t naturally type the capital letter, it doesn’t trigger the auto-accept when correct. ‘Mark typing strictly’ needs to be turned off, it should be said. Not appropriate for every course, I know - and a faff to implement.

This has saved memrise for me - at least for my own courses.

2 Likes

Thank you so much for this!!!

I had spent ages creating a course, only to realise after that the ‘auto accept’ left it close to being null and void.

I’ve spent near on half a day trying to find a solution!!

1 Like

That is such a beautifully simple way to solve the problem of ‘auto accept’!!

Aaaaa!!! :slight_smile:

Why not just make ‘auto accept’ an option?

My course a lot of the time tests the users knowledge of adjective and verb word forms for singular and plural; masculine and feminine; and first, second and third person. The different forms are usually very similar words.

My course is a Romanian language course for English speakers.

The singular masculine form for ‘good’ in Romanian is ‘bun’, the plural feminine form for ‘good’ is ‘bune’.

If the the learner is asked for the singular masculine form for ‘good’ in Romanian, and they think it is ‘bune’ when actually it is ‘bun’, they can still get it ‘incorrectly right’ (if you see what I mean). As soon as the learner types the ‘n’ in ‘bune’, the system gives the correct answer for ‘bun’, even though ‘bune’ was going to be written.

I believe the site works on science/psychology/neuroscience (whatever) based algorithms, so the ‘auto accept’ feature, when considering what I wrote above, seems to leave the science and algorithms behind the site null and void under these conditions

2 Likes

How about this - add a space at the end of words? Also less intrusive than the capital letters scheme.

But I agree of course - I wish they would add an option. In the meantime…

+1

I would be fine with auto-accept if it was consistent.

Some answers auto-accept, some don’t. When they don’t, I wind up second-guessing myself, perhaps changing my answer, hit ‘enter’ and then see that my first answer was right and it just didn’t auto-accept for some random reason.

My rate of wrong answers massively increases with this feature.

2 Likes

In my experience, it’s probably a case of just omitting a punctuation mark or diacritic. Annoying, isn’t it?

Sometimes it’s not including a full stop or question mark, sometimes it’s having or not having a capital letter at the start, but sometimes it just doesn’t work at all.

1 Like

Yep! That’ll do it.

I haven’t noticed that…yet!

That’s interesting because mine has improved. If my answer doesn’t get auto-accepted, I usually have time to correct it, if it’s something simple like a missed punctuation mark, accent, initial capital, etc. That’s not always possible for long phrases, of course and it’s probably not the case if you are learning a language that, for example, doesn’t use the Roman alphabet.

1 Like

Nice update! Thanks

“guessing” does not help learning, Alan, maybe your mistakes rate is lower when memrising, but in real life…