Memrise does not let me set my language

I have set Memrise to speak English. My memrise-laptop “speaks” German, probably that is why memrise keeps opening in German?

I dislike the German version of Memrise - dislike this “Du” all over the place - and wish to keep the language English. But Memrise does not let me… keeps speaking teenager German with me…

(at least English seems “oblivious” to politeness; I’d prefer a more polite or at least neutral language, but memrise does not have that on offer)

2 Likes

memrise, please stop changing my settings!

1 Like

Could you please explain this issue in more details?

I set my laptop to German and the website was shown fine in English.

I’ve also set my laptop to English and changed the website to German and was also shown fine.

Did you by chance happen to set your browser to translate Memrise from English to German.

Of course my Firefox - latest version - is set to delete whole history and cookies when closing. But until yesterday around midday everything was absolutely fine; now everytime when I log in I have a German dashboard, and I have to “speichern/save” English as standard language, every time, with the same result…
thanks!

(p.s. And no, I dont use any translation apps, save for Perapera (Chinese) and the Digital Pali reader)

Hi
I had the same problem a few days ago. I use Chrome not Firefox.
Several times I had to change the language setting to English. But than suddenly … it works.

I don’t know what happened.

Could you log out of the website and change the language to English?

@Joshua, many thanks, I’ve done that, but the settings last only as long as I mark “allow” that “d10… cloudfront.net” script in my “noscrypt” add-on. That script might be the “culprit”. I know that the script was there long before this issue appeared - never made problems before, even if not allowed…

no change here?

Does this issue persists in Private Browsing mode?

someone from the staff tinkered with my settings long ago, and for several years it was OK, I saw my memrise in British English. But now the problem reappeared: does nor matter that I’ve set my interface language to English UK, years ago, Memrise is still trying to compel me to use German - the language of my laptop device. Especially on course pages, German suddenly appears all over. Dashboard seems fine. I am using latest (canonical) firefox on an ubuntu fossa device, always in private mode and with ublock and noscript installed. Worked just fine until 3 days ago.

(I dislike profoundly this habit of addressing everybody with “Du”, so i prefer a language which lost long ago the politeness pronouns)

dear @MemriseSupport, could i get an answer: why memrise is changing my UI language constantly - from English (I want it UK English- but since yesterday memrise apparently wants me US, which I do not want) to German and back, and so on and so forth.

thanks!!!

Hi @Angharad.Merfin, sorry to hear that.

I can confirm the UI should appear in the language you choose in your settings, which I can see is currently English.

Could you try the following steps?

  • Please make sure AdBlock, AdBlocking technology or Ghostery have been disabled
  • Clear cache and cookies
  • Disable any active extensions and/or userscripts
  • Ensure your browser is updated, and restart it

If the issue persists, please confirm which browser you’re using and if the problem occurs in incognito mode as well.

We look forward to your response.

2 Likes