Learning Settings (number of words) not being followed

iOS user here. I’m the last day or so, the learning settings for number of new words to learn have not been working. I have always had it set to the maximum of 10 words, and suddenly the app will only let me learn 3 new words at a time. I have tried deleting and reinstalling the app and that has not worked. I get the same result no matter the course.

6 Likes

Hi @matthewbierwirth,

Some of us have reported a similar issue with the number of items for review, which are reverting to the minimum “10 words” everytime we log on. I can only get round this by going into “Settings” each time I log on and re-setting my preference. Are you doing the same with your ‘learning’ setting?

I hope they come up with a fix soon!

2 Likes

Yep. Actually, the setting continues to show 10 for words to learn, but when you actually go to learn new words in a course it only gives you three.

2 Likes

Absolutely second this. It was after the update to the ios app Yesterday (that was ironically for bug fixing). Really annoying as learning 30 words a day this way takes forever and I feel I am not learning them really as its the same words in a row whereas i feel I learn more when there is a bigger gap between them

1 Like

I know! Sometimes with 3 new words at a time you get the exact same question (format and everything) two or three times in a row!

I wish they would add a way to increase words to learn to 20, 30, or even 50 at a time.

The Android app always used half-planting for 10 (max) words.
I liked this approach recently when I tested it for offical PT BR 6 + 7 courses, as I could mass half-plant multiple words on several levels all at the same time.

The benefit: The review queue was not filled…and I was able to get “introduced” to some words even I did NOT want to review them 4+12 hours later (by “all typing” script on the web).

Normally I just plant 10-15 words on the web portal in one learning session…and all words are added to my review backlog queue for later.


Is this the same on IOS like the planting words on Android?

You can make good usage of multiple “half-planted” words when your backlog queue is huge and not zero.

Sometimes I am not in the mood to first review all words and phrases on the web portal…but I want to learn a few new words nevertheless.

This (very great - but not customizable) Android app feature made it possible that I pushed forward with the last offical PT 7 course when I had 1-3 really good days.

Well alot of the time you may get 7 new words a review session but not complete them all. Then in the next session you would get a few new words and continue growing the other ones. However with this bug you basically always complete the 3 words every 2 sessions because that’s all you are studying and it sucks because hearing La casa 3-4 times in a row is not helpful for learning because I am not thinking what it is.

1 Like

Yep. Just tried it again. The workaround of resetting my preference for reviews works but doing the same thing for planting doesn’t. Will have to get round it by using the web version for planting.

@BeaTrisy - is a fix for this coming anytime soon, please?

Yeap. All true. They need to fix this bug quickly

2 Likes

Hi all,

Thanks for getting in touch.

We are aware of this issue and our developers have a fix pending! This should be available as soon as the app get’s reviewed and approved for the AppStore. Please keep an eye out for the next update.

I hope this helps for now.
Beatrisy

6 Likes

Thanks @BeaTrisy. Will keep a look out for it.

@BeaTrisy thanks for the update. Can I confirm if that means it has already been submitted and we are just waiting for apples checks to go through?

Thanks

It would be great to know when the update is scheduled. The learning mode have become completely useless … So any updates here?

1 Like

Thanks but please dogfood your iOS releases a bit better. This is a very big bug that should never have gotten past internal QA!

When will this bug be corrected? I much rather learn on my phone than a the computer :slight_smile:

@BeaTrisy, the iOS beta version v1.0.212424 still has the bug. Hopefully you’ve submitted a different version to Apple…

Same here. Glad I’m not the only one. Reported the bug early last week but haven’t gotten anything back from them. I noticed that it happened after last Monday’s update (March 19), but I also notice that that update no longer shows up in the update list.

Hi guys,

Update today has fixed this issue!

Whoop whoop

The update has been approved and you should be getting it on your devices shortly. v2.3.19

Thank you all for your patience, and Happy learning
Beatrisy

1 Like

Today’s update now allows me to learn more than 3 new words in a session but the old problem with reviews has not been fixed. Each time I log off and back on again, my review preference of 25 words still gets reset to 10.

I think I’ll give up on the app version. :disappointed: