Launching Presentation Cards and Preview (Alpha)

This is basically some crossposted info from this post, but here’s the first release we’re doing on the web with the new Learning Sessions before we get the Memrise Labs toggle live…

We’ve spent the last week setting everything up and updating what we call the ‘Presentation Card’, which is the screen you see when you’re first introduced to an item, or when you’ve got it wrong.

We’ve made some slight hierarchy improvements to the information that’s presented, as well as updating the container UI to look a bit more modern and Memrisey.

If you want a sneak peek of what the new Presentation Cards feel like, you can check them out in the rather hidden ‘Preview Mode’. To access this, go to the page of a course you’re learning (French 1, for example) and click on one of the levels. Click on the ‘Options’ button below the progress bar and click ‘Preview (Alpha)’. This will take you into a session that just has Presentation Cards on it.

Feedback and bugs welcome!

11 Likes

First things that seem to be obvious when comparing your screenshots:

  • The title is truncated (“French 1” as opposed to “French 1 - Getting Started!”)
  • The word to be learned and its translation are not prominent enough (compared to all the other info)
  • The Pause button is missing
  • The “number of words to be learned” is missing
  • The Help me remember this Button is missing
  • The Less link is missing

I would have tried it out myself, but the procedure you mentioned here …

… isn’t working, IOW I don’t see a Preview (Alpha) entry. All I ever get is this:

image

I’ve tried this with a community based course as well as an offical Memrise course (the screenshot being from the latter).

2 Likes

Olaf - To access ‘Preview’ mode, you need first to open a Level and then go to ‘Options’. You should find you can access the Alpha then. It’s working ok for me.

5 Likes

Please tell me you are going to include displaying the alternatives for words and definitions in the new preview. And also the attribute columns set to be shown at tests. They’re all missing now.
Also no mems or link to editing a word.

What are those keys in the Keyboard Shortcuts? Only space and enter to go to the next word work for me.

2 Likes

Luke,

It would help enormously if, when announcing each of the new alpha changes, you tell us what your thinking is for making the change(s). For example, why a particular element that we have become used to seeing has been removed or why an element is being given greater prominence.

That would give us a better understanding of what you are aiming for and allow us to make more useful comments and suggestions.

7 Likes
  1. Italics (meaning and written form) is not the best font for learning; this font should be plain and simple, not distracting or straining your eyes
  2. Four-finger hand is frigging horrible, the sooner you get rid of it the better
  3. There’s no ‘go back’ button in preview mode now and I don’t see it in the alpha. But this button is much needed - every time you misclick on ‘next’ you should start preview session again, which is really unfortunate.
1 Like

Very good call. I suppose to start with we can definitely add in what we’ve added and what is coming up soon (before this gets put into learning sessions)… For everything else, it’s hard to know what people want feedback on, so I’ll just reply when people have questions.

The main thing we’ve added in here are videos on official courses. The videos are really handy for knowing how actual speakers say the items in the course, instead of the traditional, overly enunciated audio you get in most online courses (that still exists in the audio, by the way).

In terms of things we’ve removed, the only thing that won’t be shown when we release these Presentation Cards in the actual sessions is mems, but these are definitely coming back! Will be following in a future release, hopefully not too far behind. This was a decision made entirely on speed of release, but even when we release these to all users, you’ll be able to switch between the new and old designs for a time.

@duall - the alternatives should still be in there, but I’ll look into why they aren’t showing up for you. Could you provide an example? And the link to editing is being added before we properly release.

On the keyboard shortcuts, I’ll look into why all these aren’t working, but we’ll be adding all of the old keyboard shortcuts in there as we release more Learning Session types. Speed Review is up next, so a load of them will be added with that :slight_smile:

11 Likes

Thanks for the feedback!

  1. Thanks for the feedback on this. I’ll have a look at changing this.
  2. That one is definitely not changing at the moment, as it’s an established icon across all the products. I’ll log it with the design team though for when we’re next looking at icons
  3. This is a great suggestion. I’ll see whether it’ll be easy to implement with the devs. However, I know we definitely won’t put this in in a normal mode, as if you get a test wrong, a new copy of that test will automatically be put into your learning queue anyway, so you’ll see it (and you get the feedback screen for the item itself).
9 Likes

The kanji is also appearing in italics.

2 Likes

Ooooh that’s definitely a bug! Thanks for that :see_no_evil:

6 Likes

We also need to align the kanji and hiragana fonts, so adding that to the list too!

7 Likes

Thanks duaal - is it this iconography, for example, that is hard to understand?

⌘/⊞ + ⏎

It’s trying to say hold Command (Mac) or the Windows key, and press Return.

Does that work for you? If it doesn’t please say what browser and OS you’re on! Thanks.

8 Likes
  1. Yep, this hand is everywhere these days, maybe that’s why we should stop its spread.
  2. No, you don’t need ‘go back’ button in normal mode, only in preview.
1 Like

Some screenshots:

1 Like

Ah brilliant. Thanks for that!

6 Likes

None of them work for me. I’m on Windows 10 en the latest Firefox.
/ opens up a searchbox in Firefox and the others do nothing.

edit: I’ve just tested in Edge. Only Windows key + / works there.

In the course that I’ve been checking (Spanish 1), hitting the “r” key to replay the audio and hitting the windows key together with “/” to hide the shortcuts both work for me. But hitting the windows key together with “Enter” doesn’t do anything.

I’m on Windows 10 and Chrome.

5 Likes

By the way, I don’t see mems. Where have all the mems gone?

Mentioned it in another reply :slight_smile:

7 Likes

Hey Mila,

What browser and operating system are you using? I can’t seem to replicate that fact you aren’t seeing all the right fonts!

5 Likes