Just came back from long hiatus, but I can't seem to add contributors to my abandoned course?

So I used memrise in the past as a platform to compile these few words in my own, because I fell in love with its teaching technique. That course is this one:

After coming back to the site like 7 years later, I’m amazed to see that there are actually still weekly learners dedicated to that course.

Lemme tell ya, that course is FAR from its true potential, and I would love for the learners to be able to contribute any new words into it on their own. But I can’t seem to add contributors. I added the names, and when I press “Save”, it just doesn’t add in. Is this just a problem for legacy users/course, or am I missing something?

Thanks for reading.

When you add contributors by typing in (parts of) their name, a dropdown should appear that carries the matching name(s) found by the system. Click the correct name so that it appears in the textbox, then click the Add new button, then click the Save button.

FWIW, I just tested this out and it seems that only people who you follow show up in the list. This might be a new bug, but to work around it it might be enough to add the desired contributor to your “friends” list and then add them.

@MemriseSupport, @MemriseMatty: can’t you add a new contributor unless (s)he is on your friends list?

I appreciate your fast response! Will definitely go ahead and do that for now.

Hi Olaf,

Yes, the text box will appear if you start typing the username of someone you follow but, as far as I know, it has never shown in other cases. I guess the number of options would be to many.

I have just successfully added you and nisbahmumtaz as contributors to my test course without your workaround. It’s strange that nisbahmumtaz was unable to get new contributors to save.

1 Like

Well, the procedure is not very straight forward - you have to click both the Add new button and the Save button. I forgot to click the Save button myself not all too long ago! :slight_smile:

It also works for me if I type in the username and then click “Save” and then “Save” again (without clicking on “+Add new” at all). :crazy_face:

1 Like

Welp, I tried this out immediately, and got it to work… once.
Then when I tried to add in more members, it removed my already invited contributors, and no longer allowed me to add in even the ones I had in my following list.

So it didn’t really work. Oops.

Could you try adding me and/or Olaf as contributors so that we can take a look?

It seemed to show that it work on my end. Did it work on yours?
If I leave the contributions tab, and reenter it, everyone just disappears. So for now I’m keeping it untouched to see if you could access the course.

No, it hasn´t worked.

It looks like you may have to wait for one of the Memrise team that Olaf tagged to take a look.

1 Like

I’m in no hurry. All the responses so far are very much appreciated.

3 Likes

Any joy @MemriseMatty in solving this issue/ bug?
(From what I’ve read it seems a bit hit & miss - ie some work and others don’t.)

Hi all,

Thanks for reporting this.

Our developers investigated this issue and found out that it happens when the course creator is listed as a contributor to their own course. Removing the creator from the list should allow you to add more contributors.

Please rest assured that you will still be able to edit your own course even after removing yourself from the Contributors.

@nisbahmumtaz Could you please test this and let us know if it works for you?

Best wishes,
Memrise team.