Is there a problem connecting streaks from the web version to the andriod version?

Hello Everyone,

I was wondering if it’s normal that if I review words on a course in the web version it’s not counted for my streak in the app (android). For example i started a course yesterday on my laptop and since it only contained 27 words i finished it the same day. That would be more than enough points to count as a day for my streak. But if I open the app now, it says i have no streak eventough I worked on it yesterday. I have simulair problems for different courses. Does this something have to do with the fact that you can’t use streaks on courses in the webversion ones you’ve completed them?

I just want to know because streaks are kinda important to me and I want to be sure i’m not losing all of them because of this.

3 Likes

I wondered the exact same thing just an hour ago! Plus, a great deal of the courses that I am still working on (unfinished) show the same behaviour (web = points not reached, Android app = points reached).

@MemriseSupport, @JBorrego, @frabcus_memrise, @lurkmoophy: are you aware of any problems?

This happens to me too!
web = streak reached on web only
app = streak reached on web + app

This has been going on for like a month? Something is broken here.

edit: and also they differ by one: web streak = app streak + 1

Same here, I use both the web and android versions and it seems the points from the android will add up, but the streak points may or may not be counted. A few days ago I got partially to my goal on the web version, switched to android for the last 1000 points, and it put my streak points back to zero. It was nowhere near the time for switching between days, in fact it was 20 or 30 after the hour in the middle of the afternoon. I just keep working on both until they both say the goal has been reached. I have a couple of courses with a streak over 1000 days and I’ll do what it takes to make sure I don’t lose it to a glitch.

Could this be related to the previous problem that occurred on courses without a description?

I just did some testing on three courses that I had completed the daily goal on the web browser, then I did some review of them on the android app on my phone, and they all went to 0/1500. None of those courses (two mine, one another user) have a description.

I tried another that did have a description, completed the daily goal on the web, then reviewed on the android app and it still showed completed.

Another course without a description won’t open on the android app, I get a message that says “sorry there was an error loading the content” https://www.memrise.com/course/320624/vocabulaire-francais-avance/

I don’t think so. I worked through my courses this morning using the Android app and just checked the website, and there’s all sorts of courses with description where the effect shows just as well.

Hi all,

Thank you for bringing this to our attention. We’ve raised a bug to our developers on this, but so that we can get the right information over to them, can we just double check:

  • Some users are seeing that streaks are not being registered on the Android app after completing lessons on web, and vice versa.
  • Some users find that when they go into the app after completing the necessary points on web, their streak resets to 0.

Please let us know if we’ve missed or misunderstood anything.

Looking forward to hearing from you,
Memrise team

2 Likes

Streaks problem is a couple months old. I suppose it is related to new dashboard view.

See this thread:

For one, I still have this discrepancy:

I have this problem as well, between the webpage and Android app. What I have also noticed that the streaks don’t necessarily always match. For example on one course I reached my goal on the web and was told my streak was 369 days. Opened the app on the phone where it said that streak was 368 days and goal not reached. Reached the goal on the app and got to 369 days. Went to the webpage again where the goal had reset (again!). As a test, made enough points to reach my goal AGAIN and was told that my streak was now 370 days. All within about 15 minutes.

And yes, this problem has been going on for quite some time.

Hey guys, I am using Memrise on both the app and web and I am having this same issue. Sometimes on the web it shows that my “daily goal” has been completed even though I haven’t done anything. And when I go and complete it on my phone and then go to the web again, it resets the “daily goal” for that day !

Anyways, I don’t really care about the streak to be honest. But can anyone confirm if it also messes with the words I have learned ? i.e does it register I have already learned some words when I haven’t ? I don’t want to miss any words.

I don’t think it does. I’ve had a few occasions when I had to learn words twice, but I didn’t notice any pattern behind this and it has only happened 3 or 4 times over the past 6mo.

Last week I saw something new. I did a break for a couple of days and either have not scored at all or scored a few points, but not enough to prolong a streak. To my surprise two days later my streak was renewed, though it should not be. This streak system is certainly a bloody mess.

1 Like

There are a ton of problems with goals and progress tracking - especially when using multiple devices and learning more than one course. The problems I’ve seen so far - in both Ios and on the web client are:

Goal tracking “Goal Completed” are fundamentally broken. Right now on my homepage (Firefox and Chrome) I’m showing a course I’ve dont done recently as “Goal Completed” when it should be showing 0/1500.

iOS: the app will show all courses you are learning as “goal complete” even after any course has been studied on a given day. It is out of sync with the web - which is also broken. The progress meter is also incorrect (the circular progress bar).

Since these are impacting both clients - it appears to be not part of the web or app infrastructure, but more associated with the centralized progress tracking that should sync across all devices and platforms.

There is also no way to submit screen shots or debug files in their bug submission process which should be simple core functionality. As a paid subscriber, I’m very dissappointed that this problem keeps persisting.

Sadly, its November and there is no sign of them fixing these issues anytime soon.