Introducing: Beta for new web experiences

Greetings! We’ve been busy building our re-invigorated learning modes for the last few months, fixing bugs, paying back technical debt so we can improve the web app faster in future and enhancing the user experience with bold new designs. There’s been great positive and constructive feedback through Memrise Labs experiments (the funky Alpha version of things). We’re setting the foundations for the future and the general thoughtfulness of feedback comments has been amazing.

Some of the new learning mode designs that are in Memrise Labs are almost at the stage to share with more people. These will be available through a new Memrise experience (our Beta programme) in a few weeks’ time. Watch this space for more information!

Beta will allow more feedback from a wider variety of users, part of the process to get new look modes ready in the best way for full production. Some modes in Beta will have features yet to be added, such as ongoing enhancements to the screen shown at the end of a learn or review session, that are planned in the next few months.

One thing we’re aware of is that people have found all sorts of ingenious ways to customise Memrise with their own scripts and add ons. We’re all for this and people finding ways to tailor Memrise to their own learning, so we’re giving everyone a heads up that non-Memrise scripts and add ons will probably need modification to continue being compatible with learning modes, due to technology changes.

Beta will be an opt-out experience that is shared with a subset of users at first, so we can check it is working as intended. If you’d like to keep the existing Memrise design for now, you’ll be able to easily turn Beta on and off in a few clicks, via the Settings screen.

8 Likes

Just done what I thought was an Alpha preview on a Community course and the screen for planting shows the hand with a BETA.

But the issue I’ve found is that the audio does NOT play automatically for the first item (it will if I click the speaker icon). But is DOES play automatically on subsequent words (irrespective of what I did on the first).

It’s ► this course

A post was split to a new topic: Multiple-choice “wrap-around” problem

Hi DW7.

You found the Beta tag that we put on Preview mode quickly! We’re in the process of getting both Preview mode and Speed Review mode ready for Beta. Next time we are moving a mode from Alpha to Beta, we’ll add the label later on in the process to minimise confusion.

On the audio issue you experienced, could you provide your browser version and anything else you did. Are you able to replicate the issue? I cannot replicate it on Chrome version 86.0.4240.111 (Official Build) (x86_64), trying just now. Please would you provide the browser information and @ale_c in our Customer Success team can pick this up with you and get to the bottom of it.

3 Likes

Many thanks @Adam_Spooner68 and @ale_c for your interest.

I have an up-to-date Windows 10 and use up-to-date Firefox - Version 81.0.2 (64-bit).

I also have MS Edge (which I hardly use) and weirdly it works fine on that.

(It’s still an issue for Firefox but it works fine when I click on the speaker icon :speaker:, so it’s not really worth concerning yourself about it.)


PS

Firefox has just been updated to 82.0.2 but the issue continues.

I have this issue all the time on the regular website. When previewing but also for some music courses when reviewing. With the latest Firefox on both Windows 10 (64-bit) en Android 10. Not with Edge (which i don’t like to use).

It’s rather annoying with reviewing music courses when the first question is an audio question and I can’t answer it. Reported this some four months ago but never got an answer.
In this course for example:

1 Like