Images not showing in my course

Hey gang,

I’m not sure if i’m not doing this right. I’ve created a Vietnamese language course and have uploaded both audio and image/gif files for all the vocabulary. However while the audio works fine, none of the images appear when I test the course on PC or Android. When I edit the course all the uploaded images and gifs are all still there. What am I missing?

How have you got the “Edit Testing Direction” field set?

4 Likes

Since I have no idea what that is or where to find it, I’m going to say no. How do I change that?

From the “Edit course” page, click on “Show/Hide” for the first level (assuming your course has more than one level), then click on the grey pencil (arrowed in my example below) to display the “Edit Testing Direction” dialogue box:

Then set the drop-down menus depending on how you want items to be tested and then click “Save” and then “Back to Course”.

If your course currently only has a single “Level”, it’s better to add a second one, even if you don’t populate it at first, as this makes more editing features available to you.

Good luck! Come back if you need to.

4 Likes

Thank you, however that didn’t quite achieve what I needed it to. While that function replaced my English translation prompts with my uploaded images, I need both the English translations and the corresponding images shown at the same time. I’ve seen this done in other courses I know its possible.

Hi @HappyHayden.

In this other course - https://www.memrise.com/course/500840/a-finnish-course-in-pictures-with-audio/ - I have columns for Finninsh, English, Audio and Image (plus an attribute column for ‘part of speech’). I have it set to ‘test on Finnish’ and ‘prompt with image’. The “more/less” button is then used to display the English translation for those people who want to see it displayed during the learning phase. During tests/reviews the English translation only shows after a wrong answer (if the “more” button is turned on). I have included an explanation in the course description which can be seen on the web version. Here is an example item from the course:

Would something like that give you what you are looking for?

Edit- I should have added that, if you want the English translation to always display (without the need to click on “More”), you can do this by selecting the “Always show” option in the “Edit Column” area (by clicking on the blue pencil which appears when you hover to the right of your column header).

4 Likes

Progress!! This did the trick BUT only on the laptop. The change is not being reflected in the lessons on Android. Any solution for that??

Hi @HappyHayden,

Happy New Year!

Glad to hear you made some progress, anyway. Sorry, I don’t currently use Android - only the Web and iOS versions. I have just checked my two courses referred to above on iOS.

For example, when learning new words, I’m shown the “Finnish”, the “Picture” and hear the “Audio” but am not shown the “English” translation. On the second screen, I get the “Picture”, multiple choice “Finnish” (or a typing test) plus the “attribute” but no “Audio” or “English” translation. On reviews, I’m shown the “Picture” and either a typing test or multiple choice but only get the “Audio” following a wrong answer. I don’t think there is any way you will get more than that on the app versions.

On the iOS version you need to set your audio preferences in “Settings” but, looking at the FAQ section for the Android version, it looks like that option may not be available to you.

Sorry I can’t help further. Maybe there’s a tech wizard lurking nearby who knows a workaround…

4 Likes