How to use Memrise2Anki

Here’s how to use Anki and the Memrise2Anki extension to bulk-download all mems you’ve selected on a specific course:

  1. Download and install Anki

You can download it here: https://apps.ankiweb.net/. Click Code and then Download ZIP. See Olaf’s message below:

  1. Download the Memrise2Anki add-on

In particular, you want this fork: GitHub - realmayus/memrise2anki-extension: An extension for Anki 2 that downloads and converts a course from Memrise into an Anki deck.

It fixes some bugs that prevented you from using it properly.

Check their How to install section.

  1. Download and convert the Memrise course

In Anki, you should now be able to see the “Import Memrise Course…” option under Tools.

Enter the URL of the Memrise course to import:

Then, edit the relevant sections to make sure the information is mapped onto the right fields in Anki:

  • “Front” means what you will be shown (i.e. the question or definition).
  • “Back” means what is shown to you when you click on “reveal answer” (i.e. the answer to the question).

In this case, you might want “Mem” to appear in the “Back”.

  1. Confirm and you’re done! You’re ready to study your new deck of mems in Anki

5 Likes

I tried to use this on an iMac and got a popup to login to memrise which I attempted. I got the following error:

AttributeError: ‘NoneType’ object has no attribute ‘find_all’

Has anyone had any success with this? I’ve tried to download several courses dozens of times but so far it has only worked once. The rest of times it always gets stuck anywhere between 15%-70%.

Also, will we able to download courses with mems after December 31?

1 Like

At last you show some sympathy. Thanks.
I got it to work with the kanji course I’m doing, using the latest Anki version on my Macbook Pro

1 Like

Seems to work fine for me.

Do you get any error messages regarding connection at this stage?

No, I don’t get any error, it simply stops downloading at some point. Also, I managed to successfully download another course, but so far it has only worked 2 times out of dozens. It’s frustrating.

It might be helpful to log into the site in your browser, while the downloading process is stuck, and try to load a couple of pages there. I didn’t get this problem with memrise2anki but some scraping scripts might be blocked by a site, because too many similar requests from the same address might look like an attack.

I tried downloading while reviewing some courses on the website, to no avail.

The only other thing I can think of that’s blocking your downloads are your anti-virus and firewall settings.

Can you share a link to a course that is not downloading for you? Preferably one in which you have the least study history.

I tried to use Memrise2Anki after adding to anking and I’m getting this:

Error
An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue on the add-on support site.
Debug info:
Anki 2.1.49 (dc80804a) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Windows 10
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2021-12-12 03:23:22

Caught exception:
Traceback (most recent call last):
File “C:\Users\Lawrence Krosendijk\AppData\Roaming\Anki2\addons21\2071525018\importer.py”, line 210, in accept
if self.memriseService.login(self.usernameLineEdit.text(),self.passwordLineEdit.text()):
File “C:\Users\Lawrence Krosendijk\AppData\Roaming\Anki2\addons21\2071525018\memrise.py”, line 773, in login
for field in form.find_all(“input”):
AttributeError: ‘NoneType’ object has no attribute ‘find_all’

I’m using windows by the way. I already turned of my antiivirus. Does somebody know how to fix this problem?

It happened when you tried to log in into Memrise account? I have the same error.

It happens when I try to log in yes.

I’m also running into the problem mentioned above. Has anyone resolved this issue yet? Doing everything manually or even scaping my courses would take up so much of my time…

Edit:
I found this apparent solution on the ankiweb site. I can’t get it to work, but maybe someone else can.

''To make it work after installation go to C:\Users[USER_NAME]\AppData\Roaming\Anki2\addons21\2071525018
Open memrise.py in a text editor and replace all “www.memrise” with “app.memrise”."

2 Likes

Hey Christietje. I tried doing that but it wouldn’t work. I figured I wasn’t finding all the instances off www.memrise I needed to change, so I did the following and it worked:

  1. I installed the add-on using the code from AnkiWeb (code 2071525018)

  2. I downloaded the Zip file from GitHub (You can find it here GitHub - wilddom/memrise2anki-extension: An extension for Anki 2 that downloads and converts a course from Memrise into an Anki deck. in the “Code” button). It has all the same files as the add-on from AnkiWeb, but with the “app.memrise” change already made.

  3. I went to the folder where the add-on is installed, which as you point out is C:\Users[USER_NAME]\AppData\Roaming\Anki2\addons21\2071525018

  4. Replaced all the contents in that folder with the contents of the zip file.

After that the add-on worked fine for me.

EDIT: I just realized you don’t even need to do all that. You can just download the Zip file and unzip it directly on the addons21 folder and it’ll work that way too.

4 Likes

Where do you download this from?

The README at GitHub - realmayus/memrise2anki-extension: An extension for Anki 2 that downloads and converts a course from Memrise into an Anki deck. also starts with a similar instruction, “1. * Download the ZIP-file from github” - and also doesn’t link to where that ZIP file is.

I looked under tags, and there are no releases at all. When I look at the latest tag (1.2.5) at Release v1.2.5 · realmayus/memrise2anki-extension · GitHub there is a .zip file there but it is labelled “Source code”, so that doesn’t seem like what you’d want to download.

How are people expected to follow these instructions when it just says to download something without saying where to find that something?

I see your pain, Git is just a PITA at times, particularly for (but not limited to) non-developers.

3 Likes

Oh, huh! I actually use github enterprise at work, but nobody every uses that feature so I had never seen it. But… that does seem to be a ZIP of the source code, where I was expending some build artifact, so even if I had known about that feature I would have assumed that is not what the install instructions are referring to. Now I know that it is.

@Christietje @eric.auerbach.71d9 thank you, good people. Anki is really something. You have to have a lot of free time to make it work.

BTW, can someone tell if there’s a speed review mode in the Anki Android app? I can’t find it.

I’m getting an error through Anki, I can’t download my courses

It finally worked! I’ve just imported one deck as a test.

Now there’s something else I ran into: my course got made into one huge deck instead of a deck and subdecks (like the memrise courses and levels). Does anyone know of an easy way to create subdecks while importing or do I have to do this manually as well?

Now I remember why I prefer using Memrise over Anki again… the learning curve is huge.