How to fix loading problem in application

Although I have offline courses, I am having problem while loading courses for a week on Memrise application on my Android phone. I’ve tried to clear cache, also uninstalled the virus program that I use. I’m closing the app and reopening it doesn’t work anyway. Could you help me how to fix it please?

Yeah, this is a recent problem, I have it on my device, too.
Try to turn off and on your internet connection or VPN, sometimes it helps.

Hey @MemriseSupport, what about this loading problem? Are you working on it?

Hi all,

Thanks for reaching out and apologies for the delayed response- it’s been a busy few weeks!

The Android team are definitely aware of the issues users are facing with loading times. A fix is being looked into, however we don’t have an expected timeframe for this at the moment unfortunately :frowning:

Once we have any updates on this, we will let you know.

Thanks so much for your patience,
Memrise team

1 Like

I am also having this issue, does someone have any solution for this?

If all already mentioned didn’t help, try restarting your device. Worked for me at least twice!