How can I make a course?

Hello Everyone, I am wondering how I could make a course. I tried making one for my favorite book series but every time I press the ‘Create Course’ button after I’m done filling out the form it doesn’t work and keeps saying This field is required. I can’t seem to make it work. If you have a solution for my problem please let me know :blush:

1 Like

Hi @KOTLC_Faith ,

Is it when you do the “I’m not a robot” (reCAPTCHA) stage that you get the problem?

I have just tried and only needed to complete the “Name”, “Teaching” and “For” fields and then checked the “I’m not a robot” box, and clicked “Create course” and everythig was OK. If I clicked “Create course” without ticking the ‘robot’ box, I got the red “This field is required” error message.

If I remember corectly, when creating your first few courses, it requires you to complete the ‘robot’ process by clicking on the relevant parts of the image that is displayed. Sometimes it’s easy to miss one of the pictures and it makes you repeat the process. Is this where you are getting a problem? If not, maybe you could post a screenshot of the form so that I can see what else it could be.

4 Likes

Yes, but when I finish out the form and press the “create course” button it just shows the form again and it says that it’s for Afrikaans speakers but it was supposed to be for English speakers. It dosesn’t say the ‘robot’ part just ‘This Field is Required’ in bright red. I filled out the whole form I don’t see what I did wrong. I’ll post a screenshot though :blush:

Hi,

You didn’t do anything wrong! The CAPTCHA box is missing from your screen for some reason and that’s the problem. This is what it looks like on mine with the Firefox browser (it’s the same with Google Chrome):

Which web browser are you using? Are you able to try it with a different one?

2 Likes

I don’t think so, I’m just using MemRise online. It might be like that because some websites on my device are restricted. I can’t use google chrome or anything like that. Maybe that is why. (Sorry if it’s too difficult to explain)

It sounds like the Captcha tool may be being blocked on your device. When Memrise first started using it, there were problems in some countries. Memrise removed it for some time but then started using it again. This other forum topic mentions it:

I’ll tag @MemriseSupport so that they can take a look for you when they return to work after the weekend. I hope they can find a fix for you.

3 Likes

Okay, Thank you for helping :blush:

Have a good day!

1 Like

I use Firefox.

But I have add-ons that prevent pop-ups and certain things displaying.

If you have anything similar as a precaution, can you temporarily pause it and reload?

Otherwise, as Alanh says, it be a internet provider issue.

Thought - have you seen a Captcha on other sites?

1 Like

Thank you for asking @DW7, Maybe the Captcha is glitching or something but I’m not so sure. Another reason it might be acting up is because all websites, except MemRise and a few others, are restricted on my device for a reason. Or it could just be an internet issue. I don’t think that I’ll be making the course anymore :confused:, But Thank you for helping though :blush:

1 Like

Hi @KOTLC_Faith, sorry to hear you’ve had trouble creating this course. It sounds like it could be a browser or security/cookies setting issue. You may wish to try on another browser.

In the meantime, I have created it for you to edit. Please go to Keeper of the Lost Cities Quiz - Memrise.

I hope this helps for now :slightly_smiling_face:

6 Likes

Thank you so much! :slightly_smiling_face: But I decided to not make a course anymore because it is too much work and I’ve been busy this week. So I deleted it. I’m really sorry :confused: Hopefully It didn’t take a long time for you to make the course.