Homepage not connecting, app preventing upgrade


When I open the app, the homepage displays the “Oops something went wrong. You may be out of internet data” screen. (I’m not out of data, I have unlimited data but I’m on wifi atm… honestly that’s such an odd kickback message to get from an app. “Sorry I, the app, am not functioning correctly, it’s probably something you did” I’d suggest a different message.) This same screen comes up when I tried to purchase an upgrade as well using any of the in app upgrade paths (button on top right, “unlock full course” under learn tab, or through account settings.

I downloaded the app for the first time maybe a week and a half ago(?) and have always ran into this issue. I worked around it at first by entering the course through the learn tab or through the courses menu but now that the free course is exhausted, I can not continue until this is resolved. I do not have several courses downloaded, just German at first and as of a few days ago, French.

I have reinstalled and restarted twice. I do not get this error on the website and I considered purchasing a plan there and seeing if it came through on the app but I saw tell of subscriptions not appearing in app among the bug reports so I figured I’d go one bug at a time. Anyways if the app is insisting I’m not connected, I doubt it’ll register a purchase.

Device: Samsung galaxy 8
OS: android version 9.0
App version: 2021.11.24.0

I guess it’s your internet connection and/or your provider. I see this message when something is happening on my side.

Do you have a vpn? I’d try an experiment and turn it off if it’s on and vice versa.

Hi @priaj,

Sorry about this! Can you confirm what Hombre_sin_nombre has suggested?

Please also try to uninstall the app, restart your device, and then reinstall it. Please make sure you do that via Google Play Store to get the latest official release.

If this keeps happening after trying all of the above, please contact us in the app Profile > Settings > Help as this will give us access to more information to keep investigating.


I get that error message at least 3 times per day, the last time some ten minutes back. It doesn’t hurt much - tapping the three dots button (which is what I always do anyway) will “work around it”. I’ve also mentioned it at least once somewhere else, but I can’t find it.

It does look very much different here though, with a big banner at the top, but the contents resp. message (German here) is pretty much the same. I can take a screenshot if you want me to.

Same issue on Samsung Galaxy A70, running android 11 with version 2021.12.16.1 of memrise.
Been ongoing issue for around 2-4 weeks and prevents me from using the app on android at all.
No issues on the ipad or web browser on the same wifi network.
Did the uninstall-reset-install sequence – no help.
No difference with VPN.

Please reopen this issue

I tried going through profile > settings > help but that didn’t work either. (Just tap on the link and nothing happens)

Hi, thanks for letting me know.

I’ve now created a ticket for this, our team will look into it asap. Unfortunately I don’t have a timeframe for any fix yet, in the meanwhile please consider learning on a different platform if possible, e.g. https://app.memrise.com/

Thanks for your patience.