Finished courses show up as "unfinished"


(Olaf Rabbachin) #21

I can confirm that - tried that as well. :roll_eyes:


(Nathan Wilson78) #22

It seems to be related to a course having duplicate words, not just ignored words


(Olaf Rabbachin) #23

@MemriseSupport: Could you PLEASE be so kind and at least indicate that you’ve even registered that something’s wrong? Feel like talking to a wall here, regardless of which bug I report and where - NO REACTION AT ALL, NOWHERE!
It is absolutely ridiculous how you treat your PAYING customers!

</ rant>


Android bugs
(Memrise Matty) #24

Hi - Thanks for reporting this! Sorry to see you’re having these issues. We are aware of this issue re-surfacing over the past month or so.

Unfortunately I cannot confirm when this will be fixed, or provide a rough time-line (it’s unlikely this cosmetic bug will be prioritised at this stage).

I will let you know once a fix has been released or if we have another solution. I hope this helps.


(Nathan Wilson78) #25

I disagree that this is a cosmetic bug, knowing which courses are complete and which ones aren’t is key to prioritising which course to work on next and there are clearly quite a few people experiencing it.

The symptom here is that it is not summing the number of learned words in a course correctly, it appears to be double counting duplicate words in the denominator but single counting them in the numerator of the course progress. It should be a relatively straightforward fix, if I could have access to the source code I’d make a pull request to fix it myself!


(Olaf Rabbachin) #26

Well, it seems they have changed something. The message no longer appears (not at all, to be exact), so you’ll have to check the “rocket gauge” or do the counting yourself. Instead, each and every end of lesson will now trigger the dialog that did only appear when you finished a chapter.

One step forward, two steps back - that’s what I think has been the motto over the last couple of months …


(Nathan Wilson78) #27

Maybe my interface looks different, I’m not sure what message you refer to Olaf. My issue is that completed courses show as not complete - see attached screenshot. All of these courses are complete but two appear to be still in ‘learn’ mode.


(Olaf Rabbachin) #28

Sorry, Nathan, I mixed up things! I was actually refering to the streak error (see this thread). Dumb me.


(Airdramon) #29

I’m glad to know I’m not the only one with this issue. It’s annoying!


(Karen Luebkee5) #30

I have this same problem, since I was forced to update Memrise last night. (I finally made “Overlord” and it must have broken the older version of Memrise I was using.) It looks pretty much like that last screenshot with courses that I completed years ago showing up as incomplete. When I tested a course I was able to “learn” the words I’d done that now show up as unfinished.


(Nathan Wilson78) #31

Hi MemriseMatty, how can I get a refund? I’ve cancelled my premium account and want a refund for at least the rest of my time.


(Jklingen9290) #32

@MemriseSupport I’m having the same issue with my Japanese 2 course. It’s perpetually in learn mode and has an error whenever I try to actually learn. I have an ignored word (ATM). I am also using Android on a Google pixel2 phone.



(Ieuan ab Arthur) #33

Hi All:

I’m not using the Android app, but the error message that @jklingen9290 reminded me of something that happened when I was creating a course on the web. After making several updates to my course, I frequently saw the “Sorry, there was an error loading the session” warning. The issue turned out to be phantom entries (i.e., old course entries that were supposedly removed but weren’t - another memrise bug). To rule out this possibility, you might want to have a look on the phantom entires thread in Course Creators - [Userscript] Attempt to Eliminate Phantom Entries

Of course, I imagine that this error message appears any time that a course has an issue and have nothing to do with phantom entries.

Ieuan


(Riskymicrobe) #34

Four times I’ve run into the problem of completed courses not being market as complete. And it’s not always just a discrepancy of 1 word. In one case there’s a discrepancy of as many as 7 words, plus the discrepancy can be to either side of the total number of words (ie. it’s not only the numerator that is less than the denominator, but also the inverse). The problem can show up in both the web version (Chrome) and app (Android) for each completed course:


– 437/444 words learned (0 ignored words)
– Web: Incomplete (in learn mode, but cannot load session)
– App: Incomplete (in learn mode, but cannot load session)

In this course, levels 2, 4, 6, 9 are missing in the web version (seem to have previously existing but now been deleted). In the app, the level numbers have been reordered so that no “gaps” show up (ie. highest level number is 17 in the web version, but only 13 in the app). No “multimedia” levels.


– 898/899 words learned (0 ignored words)
– Web: Incomplete (in learn mode, but cannot load session)
– App: Incomplete (in learn mode, but cannot load session)

This course contains 2 “multimedia” levels (which only show up in the web version): Level 1 which is simply a credits text without any words to learn + Level 25 which is also just text without any words to learn.


– 965/964 words learned (0 ignored words)
– Web: Complete
– App: Complete

This course is marked as completed in both the app and the web version - but only very recently for some reason. And still, the numerator for learned words is strangely larger than the denominator. The course has the same number of levels in both the web version and in the app. No “multimedia” levels.


– 80/79 words learned (0 ignored words)
– Web: Complete
– App: Incomplete (and not even in learn mode)

Again, the numerator is larger than the denominator. Level 1 is a “multimedia” level without any words to learn, only a link to a Youtube video. The level only shows up in the web version, and the remaining levels have been renumbered in the app.


To me, there is no clear pattern, as the discrepancy is to both sides of the total number of words. Plus, the discrepancy can be more than 1 word, and learn mode can both be broken or not even showing up when the course is marked as incomplete. Lastly, “multimedia” levels don’t need to be present for the problem to occur, and both the web version and the app can be affected.

Ignored words seem to have nothing to do with it, as I’ve previously un-ignored words with no effect. Ignoring words merely changes the number of total and learned words accordingly. Likewise, uninstalling and reinstalling the app does nothing.

What @Ieuan_ab_Arthur says is something I’ve seen others hint at elsewhere. Perhaps these problems have to do with course rearrangements (deletions/additions/spelling corrections etc.) after initial publication? Or bugs due to “transmission errors” when updating?

Like @Nate022, I also don’t find this to be simply a “cosmetic bug”. And I also find it interesting (amusing?) that the course with the largest discrepancy of 7 words is actually an official Memrise course. :slight_smile:

Something being done about this clearly frequent issue seems way more important than actual cosmetic changes. Especially for those of us who are paying for this buggy experience.


(Nathan Wilson78) #35

Yeah - I’ve stopped paying for Memrise and moved to another app due to this bug and the lack of support from the Memrise team. Amusingly (not really), while I was offered a refund from customer support a few times during my time of patience and asking when the issue would be fixed, once I actually cancelled my subscription and asked for the previously offered refund I’ve received a complete lack of response from any of the official channels or on this course forum.


(Jklingen9290) #36

Thanks for adding this @leuan_ab_Arthur. You’re definitely right that it’s not only tied to ignored words. I’m getting the same problem in Japanese 3 and I haven’t ignored anything. There are 2 “phantom” entries that take up space but don’t exist and prevent me from completing the lesson:


(Nutmeg40) #37

Im having the same issue on my Samsung S7


(Joëlle Smits) #38

I’ve encounterd the same problems with 2 courses. There is nothing more to learn, still it says not completed.


(Olaf Rabbachin) #39

FWIW, I’ve listed this bug along with a whole bunch of others here.