Finished courses show up as "unfinished"


(Olaf Rabbachin) #1

Several of my finished courses show up as unfinished, with just a few words (2-4) to be “learned”. To be exact, 3 out of 26 finished courses show this behaviour.
I can’t tell for certain but I do think that there are “ignored words” in all of them.
The learn-button is inactive too, so you can’t just learn the buggy words.


'Learn New Words' not working
Could not load the session. Sorry. on Learn New Words
(Olaf Rabbachin) #2

Looks like the last update resolved the problem …


(Olaf Rabbachin) #3

The problem is still there. Here’s what allows me to repro the issue:

  1. It applies to courses that have been completed
  2. There is at least one word that needs to be repeated
  3. There is at least one ignored word within the course
  4. After you perform a repetition, the problem shows up

P.S.: I do really feel like I’m talking to myself. Do I need to tag someone to make somebody aware of the problem? I can’t really be the only one experiencing the problem!?


#4

I know right? I’ve got similar problems with courses I can’t complete and nobody is showing any interest in responding… We shouldn’t have to tag somebody (who?) to get a response anyway. Somebody should be monitoring the forum and giving some kind of response.


(only one user) #5

Hello @Olaf.Rabbachin :slight_smile:
I also have this problem in some courses (in my case, Japanese), but I spoke with the person responsible for the Japanese course, and she already asked the technicians to check.

Some have had a simple solution, but others are still being solved. If you want to look at the types of problems that have appeared to me, they are in these posts:

Japanese 0: incomplete course because 2 words are repeated => resolved.
Japanese 0: incomplete course again (supposedly, 2 words to be “learned”) => bug being solved.
Japanese 1: incomplete course => bug being solved.

PS: I’m sorry, I don’t speak English very well.


(only one user) #6

I had forgotten to add that I use the web version, and in your case it’s app / android. So I do not know if the problems are the same.

I believe it is important that you add the links of the courses with problems and the data of your device.

MemriseMatty always asks:

  • Device
  • OS
  • Memrise Version (you can find this in the profile section)
  • And course name

(Olaf Rabbachin) #7

Hi @Milamy,

I don’t think so. It happened to me across a whole bunch of courses, with different source (DE, EN) and target languages (FR, IT, DK, NL, S). The only patterns I can see are those that I mentioned. I should add that I have a (lifetime) PRO license though.

And RE the device: it’s consistent across two very different Android devices (a Huawei tablet and a Samsung S7).

But hey, while it’s a pretty obnoxious problem, it’s actually a tiny/minor one compared to others (like the natives hiding successfully or streaks getting lost all the time).
FWOW, over the last few months, it seems that the number of problems is growing with every single update Memrise publishes. And regardless of where I wrote something, the Memrise team did a perfect job by ignoring everything (and that’s not only me). Very sad.


(Olaf Rabbachin) #8

I just checked: it seems that this really only applies to Android! In the web version, the courses that show as “incomplete” on Android show up just as they should!


(only one user) #9

You’re right, they must be different problems.

The courses I’m having trouble with, are new courses with less than 3 weeks of release. And there are no problems with the older courses. So my problems should be more specific to the new courses I’m learning.

On the other hand, your issues should be related to the app.


#10

Hi @Olaf.Rabbachin,

I have the same issue - the courses work fine on the web but not my Android phone. Do you also get: “Sorry, there was an error loading the session”?


(Olaf Rabbachin) #11

Yes, whenever you attempt to “learn” the words that have allegedly not been learned yet.


(Rainbow Meow Face) #12

Just mentioning I also have this problem in my Android app. I have completed these courses, and they show as complete on the website, however in android they show 1-3 words off and are still acting like they have a daily goal (I turned off the daily goal on the website, no option to do so in the app, I can only set it to the lowest goal.)

Fluenz Mandarin 3 https://www.memrise.com/course/85175/fluenz-mandarin-3/
Fluenz Mandarin 1+2 https://www.memrise.com/course/75610/fluenz-mandarin-12/
CCTV Growing up with Chinese https://www.memrise.com/course/79819/cctv-growing-up-with-chinese/


(Olaf Rabbachin) #13

I’ve now submitted a bug report. I wasn’t aware of its existence.
Here’s the report form: https://goo.gl/forms/ARUn1XuSBgXL80dj2


(Nathan Wilson78) #14

I also have this problem. I’ve submitted three bug reports since it started occuring with no response or acknowledgement of any of them. I don’t think the memrise team cares


(Luke Lewandowskibc) #15

Same for me - I have quite a few “completed” curses, which after I think 2-3 updates ago started to appear as unfinished on Android.
On the web they are completed, as they should. I provide a screenshot below, it’s from the website. Course with A1 in the name appears unfinished on Android (1384/1495). The one with B2 in the name has 155/155 on Android, but 155/154 on the website :wink: I have a few more that have that incomplete bug, the one here is just an example


(Nathan Wilson78) #16

I finally heard back from memrise support.

They recommended

  • Uninstall the app
  • reboot your android phone
  • reinstall the app

It didn’t fix the issue for me however


(Olaf Rabbachin) #17

Maybe it helps to flag @MemriseSupport …?


(Luke Lewandowskibc) #18

I tried the reinstalling option before posting the message above (didn’t work).

My guess it’s another issue with counting ignored words. I have a few courses (e.g. “Spanish on the go”) which I completed a while ago, so I decided to ignore all the words there. What I see now in that course from the example is 0/2.

Maybe it helps.


(Olaf Rabbachin) #19

Maybe @MemriseMatty can help?


(Rainbow Meow Face) #20

I tried un-ignoring my ignored words I have on Fluenz Mandarin 1+2, but unfortunately it didn’t help (I only ever ignore words after “learning” them first, for reasons like having already known said word for so long it’s not leaving my memory anyway, or really odd answer formatting making things hell for the tests where you type it in). :stuck_out_tongue:
It still thinks the course is missing one word learned (it says 281/282 and shows as not finished, the website says 281/281 and shows complete.)